If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The RealPlayer plugin crashes when trying to play a RealPlayer video

RESOLVED DUPLICATE of bug 667399

Status

Plugins Graveyard
RealPlayer (Real)
--
critical
RESOLVED DUPLICATE of bug 667399
6 years ago
a year ago

People

(Reporter: Ioana (away), Unassigned)

Tracking

({crash})

Details

(crash signature, URL)

(Reporter)

Description

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0 
Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
BuildID: 20111206234556
RealPlayer Plugin Version: 15.0.0.198

STR:
 1. Launch Firefox.
 2. Load http://video.nationalgeographic.com/video/wildcamafrica/ in a Firefox tab.

The RealPlayer plugin crashes. The following message is displayed "The RealPlayer(tm) G2 LiveConnect-Enabled (32-bit plugin crashed. No report available. Reload the page to try again."
The plugin crashes at every reload too.

When loading http://www.udel.edu/UMS/itv/realplayer/test.html and playing the RealPlayer video from over there (click the "RealPlayer Test" button), the plugin crashes here too. When trying to reload the dialog with the player here,  Firefox usually freezes. If the user closes the Firefox process, the plugin-container process stays running. Until the user closes this process manually too, Firefox can be restarted but it works very slowly.
(Reporter)

Updated

6 years ago
Severity: normal → major

Comment 1

6 years ago
Firefox 9b5 crashed when loading the link from the description.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0 beta 5

This is the Report ID:
bp-ff8b1912-bab3-4097-9aba-ac5582111209

Real Player Plug-in is: 0.0.1d1
OS: Windows 7 → All

Updated

6 years ago
Severity: major → critical
Crash Signature: [@ clntcore@0x9ceac ]
Keywords: crash
Version: 9.x → unspecified
Crashes all the way back to Firefox 4.0, not in Firefox 3.6 though. Could this be OOPP related?

Comment 3

6 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> Crashes all the way back to Firefox 4.0, not in Firefox 3.6 though. Could
> this be OOPP related?

Is this specific to certain URLs, or a more significant issue with RealPlayer?
> Is this specific to certain URLs, or a more significant issue with
> RealPlayer?

I've not really tried other URLs. If we can get some test URLs I can try those. I think it is more likely an issue with RealPlayer not playing nice with plugins being on their own thread.

Comment 5

6 years ago
Can we use some of the videos at http://bit.ly/zN0rdh? Maybe http://kb.mozillazine.org/Testing_plugins? At that same URL I also saw bug 667399. We should make sure which crash we're running into when reproducing.
Keywords: needURLs
* http://www.udel.edu/UMS/itv/realplayer/test.html
* http://www.chemgapedia.de/vsengine/info/en/help/requirements/real.html
* http://www.slp3d2.com/launchsiteglobal/test.cfm
* http://www.cwdjr.net/video7/RoscoeGreetings.php (from bug 667399)

All URLs crash the same (it's a plugin crash by the way -- not a client crash).

I strongly believe this may actually be a dupe of bug 667399.

Updated

6 years ago
Keywords: needURLs

Comment 7

6 years ago
It also happens in Beta, Aurora and Nightly with no crash report on Windows.
Still reproducible on latest ESR: 
Mozilla/5.0 (Windows NT 6.1; rv:10.0.3) Gecko/20100101 Firefox/10.0.3

Comment 9

6 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #6)
> I strongly believe this may actually be a dupe of bug 667399.
You're right. The stack on Mac makes think it's a RealPlayer's bug (bug 709029) while its reproducibility depending on Firefox versions makes think it's a plugin bug (bug 667399).
I think the second case is the right guess.
Duping this against bug 667399. Please reopen if you think this is not the same bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 667399
(Assignee)

Updated

a year ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.