All users were logged out of Bugzilla on October 13th, 2018

Is there something wrong with MacOSX MoMe TryServer ?

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: sgautherie, Assigned: gozer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
1st case:
See bug 492026 comment 13: error and helpwanted.

2nd case (with bug 488175, but not the patch version attached there):
http://build.mozillamessaging.com/buildbot/try/builders/Try%20server%20comm-central%20mac%20hg%20builder/builds/371
{
Undefined symbols:
  "NS_NewHTMLLabelElement(nsINodeInfo*, int)", referenced from:
      sContentCreatorCallbacks       in libgklayout.a(nsHTMLContentSink.o)
ld: symbol(s) not found
}

It could be caused by my patches, but I wonder as they pass on Linux and Windows;
and they are ported code which work for (production) MacOSX Firefox.
(Is it just me, or that no one else has hit/reported it yet?)

It could be something "wrong" elsewhere in c-c code, but I would have no idea what.

Then, the part I'm currently less confident with is TryServer:
could there be something wrong with it: hardware (not enough RAM.?.), software (the linker.?.), mozconfig, ... ?
(Reporter)

Updated

9 years ago
Blocks: 492026, 488175
(Reporter)

Comment 1

9 years ago
(In reply to comment #0)
> 1st case:
> See bug 492026 comment 13: error and helpwanted.

Same patch, now passes: I don't know what "fixed" it in the meantime :-|

> 2nd case (with bug 488175, but not the patch version attached there):

Trying this other one again then...
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> > 2nd case (with bug 488175, but not the patch version attached there):
> 
> Trying this other one again then...

My patch now passed on TB:
http://build.mozillamessaging.com/buildbot/try/changes/448

But failed on MacOSX SM with a similar error:
http://build.mozillamessaging.com/buildbot/try/changes/450
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1270098418.1270107808.16719.gz
Try server comm-central mac hg builder on 2010/03/31 22:06:58
{
Undefined symbols:
  "NS_NewHTMLLinkElement(nsINodeInfo*, int)", referenced from:
      sContentCreatorCallbacks       in libgklayout.a(nsHTMLContentSink.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[5]: *** [seamonkey-bin] Error 1
}
The Mac box on try is a VM, and I think gozer was going to replace it with one of the new minis. So although we didn't really see issues building on production with the VMs, a mini may fair better than the VM.
Assignee: nobody → gozer
Severity: major → normal
(Assignee)

Comment 4

9 years ago
Yes, the mac try builder has been replaced with mini-10. Should speed things up and make try builds more reliable. Can you try again ?
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Yes, the mac try builder has been replaced with mini-10. Should speed things up
> and make try builds more reliable. Can you try again ?

http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTry/1270150022.1270150529.28449.gz
Try server comm-central mac hg builder on 2010/04/01 12:27:02
{
/bin/sh: /usr/local/bin/autoconf-2.13: No such file or directory
make[1]: *** [/builds/slave/sendchange-mac-hg/mozilla/configure] Error 127
}
:-/
I just starred that build - caused by a missing symlink. Try again ;-)
(Reporter)

Comment 7

9 years ago
V.Fixed, eventually :->
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

9 years ago
Keywords: helpwanted
You need to log in before you can comment on or make changes to this bug.