Last Comment Bug 547440 - New buttons in Firefox 3.7a2 don't look good if you have mode "icon and text"
: New buttons in Firefox 3.7a2 don't look good if you have mode "icon and text"
Status: VERIFIED FIXED
fixed by bug 671553 [qa!][testday-201...
: verified-aurora, verified-beta
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: Firefox 8
Assigned To: Nobody; OK to take it and work on it
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 671553
Blocks: 544999
  Show dependency treegraph
 
Reported: 2010-02-20 09:18 PST by Pavel Cvrcek [:JasnaPaka]
Modified: 2011-10-10 04:53 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot (28.04 KB, image/png)
2010-02-20 09:18 PST, Pavel Cvrcek [:JasnaPaka]
no flags Details
7 (left) vs 8 (right) (247.17 KB, image/jpeg)
2011-10-04 01:43 PDT, Danial Horton
no flags Details

Description Pavel Cvrcek [:JasnaPaka] 2010-02-20 09:18:50 PST
Created attachment 427957 [details]
Screenshot

In bug 544999 and bug 546098 were realized new icons for toolbar. It's part of Firefox 4 theme. New icons look good for me in default mode but when you change mode to "icon nad text" they don't look good.
Comment 1 Ria Klaassen (not reading all bugmail) 2010-02-20 09:29:03 PST
You mean too wide?
Comment 2 Danial Horton 2010-02-20 09:51:45 PST
To ugly actually. they don't fit in with the rest of the browser at all.

they would look alot better flatter.
Comment 3 Jonathan Haas 2010-02-20 12:34:09 PST
I think we should remove the button look completely, unless you are hovering the button.

No other Windows application displays the border of toolbar buttons (with very few exceptions). I think we can let the border of the back/forward button everytime visible, but other buttons' backgrounds should be hidden.

It currently looks very cluttered if you have many toolbar buttons.
Comment 4 Danial Horton 2010-02-20 12:47:05 PST
After a bit of usage, the border also somewhat appears on plugin toolbar buttons as well making them appear very wrong as well.
Comment 5 u88484 2010-03-03 08:55:04 PST
The mockups with the border just around the button icon with the text outside of it look really nice.  I can't find it to link to though.
Comment 6 Jonathan Haas 2010-03-14 13:20:39 PDT
One mockup is here on the bottom right:
https://bug548027.bugzilla.mozilla.org/attachment.cgi?id=428476
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-30 15:04:25 PDT
Sorry, it's not clear to me what the intended resolution to this bug is for "Icons and Text". Would it be possible to get some clarification? Thanks.
Comment 8 Vlad [QA] 2011-10-04 01:35:45 PDT
Hi guys.
Can you please answer to Anthony's request in comment7? 
I need the clarification in order to verify this.
Thanks.
Comment 9 Danial Horton 2011-10-04 01:43:24 PDT
Created attachment 564484 [details]
7 (left) vs 8 (right)

The resolution was removing the bubble appearance of the buttons unless hovered, the glow affect was also removed during hover as it made icons hard to read when certain persona's were applied
Comment 10 Danial Horton 2011-10-04 01:45:03 PDT
the Home button in the screenshot has my cursor on it, don't know why the cursor failed to show in the screenshot
Comment 11 Pavel Cvrcek [:JasnaPaka] 2011-10-04 02:04:37 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #7)
> Sorry, it's not clear to me what the intended resolution to this bug is for
> "Icons and Text". Would it be possible to get some clarification? Thanks.

For me current solution is fine. My original report was about look which looked ugly.
Comment 12 Simona B [:simonab ] 2011-10-10 04:53:23 PDT
Based on Comment 9 setting resolution to VERIFIED FIXED.

Verified on Windows Vista using the latest Nightly, latest Aurora and Firefox 8 Beta 2. The bubble appearance of the button and the glow effect were removed.

Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (Windows NT 6.0; rv:9.0a2) Gecko/20111009 Firefox/9.0a2
Mozilla/5.0 (Windows NT 6.0; rv:10.0a1) Gecko/20111009 Firefox/10.0a1

Note You need to log in before you can comment on or make changes to this bug.