Note: There are a few cases of duplicates in user autocompletion which are being worked on.

New buttons in Firefox 3.7a2 don't look good if you have mode "icon and text"

VERIFIED FIXED in Firefox 8

Status

()

Firefox
Theme
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: JasnaPaka, Unassigned)

Tracking

({verified-aurora, verified-beta})

Trunk
Firefox 8
x86
Windows Vista
verified-aurora, verified-beta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 671553 [qa!][testday-20110930])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 427957 [details]
Screenshot

In bug 544999 and bug 546098 were realized new icons for toolbar. It's part of Firefox 4 theme. New icons look good for me in default mode but when you change mode to "icon nad text" they don't look good.
(Reporter)

Updated

8 years ago
Summary: New icons in Firefox 3.7a2 don't look good if you have mode "icon and text" → New buttons in Firefox 3.7a2 don't look good if you have mode "icon and text"
You mean too wide?
Blocks: 546098
Version: unspecified → Trunk

Comment 2

8 years ago
To ugly actually. they don't fit in with the rest of the browser at all.

they would look alot better flatter.

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

8 years ago
I think we should remove the button look completely, unless you are hovering the button.

No other Windows application displays the border of toolbar buttons (with very few exceptions). I think we can let the border of the back/forward button everytime visible, but other buttons' backgrounds should be hidden.

It currently looks very cluttered if you have many toolbar buttons.

Comment 4

8 years ago
After a bit of usage, the border also somewhat appears on plugin toolbar buttons as well making them appear very wrong as well.

Updated

8 years ago
Blocks: 544999
No longer blocks: 546098

Comment 5

8 years ago
The mockups with the border just around the button icon with the text outside of it look really nice.  I can't find it to link to though.

Comment 6

8 years ago
One mockup is here on the bottom right:
https://bug548027.bugzilla.mozilla.org/attachment.cgi?id=428476

Updated

6 years ago
Depends on: 671553
Whiteboard: fixed by bug 671553
Target Milestone: --- → Firefox 8

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Sorry, it's not clear to me what the intended resolution to this bug is for "Icons and Text". Would it be possible to get some clarification? Thanks.
Whiteboard: fixed by bug 671553 → fixed by bug 671553 [qa+][testday-20110930]

Comment 8

6 years ago
Hi guys.
Can you please answer to Anthony's request in comment7? 
I need the clarification in order to verify this.
Thanks.

Comment 9

6 years ago
Created attachment 564484 [details]
7 (left) vs 8 (right)

The resolution was removing the bubble appearance of the buttons unless hovered, the glow affect was also removed during hover as it made icons hard to read when certain persona's were applied

Comment 10

6 years ago
the Home button in the screenshot has my cursor on it, don't know why the cursor failed to show in the screenshot
(Reporter)

Comment 11

6 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #7)
> Sorry, it's not clear to me what the intended resolution to this bug is for
> "Icons and Text". Would it be possible to get some clarification? Thanks.

For me current solution is fine. My original report was about look which looked ugly.
Based on Comment 9 setting resolution to VERIFIED FIXED.

Verified on Windows Vista using the latest Nightly, latest Aurora and Firefox 8 Beta 2. The bubble appearance of the button and the glow effect were removed.

Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (Windows NT 6.0; rv:9.0a2) Gecko/20111009 Firefox/9.0a2
Mozilla/5.0 (Windows NT 6.0; rv:10.0a1) Gecko/20111009 Firefox/10.0a1
Status: RESOLVED → VERIFIED
Keywords: verified-aurora, verified-beta
Whiteboard: fixed by bug 671553 [qa+][testday-20110930] → fixed by bug 671553 [qa!][testday-20110930]
You need to log in before you can comment on or make changes to this bug.