Last Comment Bug 671553 - Remove the navigation toolbar's custom button appearance in small icons mode; invert icons on dark personas and glass
: Remove the navigation toolbar's custom button appearance in small icons mode;...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All Windows 7
: -- enhancement (vote)
: Firefox 8
Assigned To: Dão Gottwald [:dao]
:
: Dão Gottwald [:dao]
Mentors:
: 586912 (view as bug list)
Depends on: 673164
Blocks: 547440 580194 670565 673695
  Show dependency treegraph
 
Reported: 2011-07-14 07:52 PDT by Dão Gottwald [:dao]
Modified: 2013-11-12 00:56 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (25.80 KB, patch)
2011-07-14 07:52 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
patch v2 (26.12 KB, patch)
2011-07-15 11:56 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
patch v3 (26.32 KB, patch)
2011-07-15 20:05 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
patch v3 (26.30 KB, patch)
2011-07-15 20:06 PDT, Dão Gottwald [:dao]
shorlander: review+
Details | Diff | Splinter Review
Screenshot (701.47 KB, image/png)
2011-07-21 06:29 PDT, Stephen Horlander [:shorlander]
no flags Details
Must be implemented on Tab Scroll Buttons too (6.82 KB, image/jpeg)
2011-08-14 03:29 PDT, bogas04
no flags Details

Description Dão Gottwald [:dao] 2011-07-14 07:52:02 PDT
Created attachment 545910 [details] [diff] [review]
patch
Comment 1 Dão Gottwald [:dao] 2011-07-15 11:56:24 PDT
Created attachment 546204 [details] [diff] [review]
patch v2
Comment 2 Dão Gottwald [:dao] 2011-07-15 20:05:44 PDT
Created attachment 546273 [details] [diff] [review]
patch v3

another untested patch!
Comment 3 Dão Gottwald [:dao] 2011-07-15 20:06:59 PDT
Created attachment 546274 [details] [diff] [review]
patch v3

typo eliminated
Comment 4 Dão Gottwald [:dao] 2011-07-18 11:13:43 PDT
I'm back home and was finally able to test this. The latest patch appears to be working as expected.
Comment 5 Stephen Horlander [:shorlander] 2011-07-21 06:27:38 PDT
Comment on attachment 546274 [details] [diff] [review]
patch v3

Review of attachment 546274 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! Currently missing inverted icons for New Tab, Panorama and dropdown markers. Should we handle those in followup bugs?
Comment 6 Stephen Horlander [:shorlander] 2011-07-21 06:29:26 PDT
Created attachment 547385 [details]
Screenshot
Comment 7 Dão Gottwald [:dao] 2011-07-21 06:41:15 PDT
(In reply to comment #5)
> Currently missing inverted icons for New Tab, Panorama and
> dropdown markers. Should we handle those in followup bugs?

Yes. Bug 580194, I guess.
Comment 9 Siddhartha Dugar [:sdrocking] 2011-07-21 09:49:16 PDT
Nice work! But I found an issue.
Put the sync button next to the tabs. Now do a sync.
The sync button changes to a back button. Please fix this.
Comment 10 Siddhartha Dugar [:sdrocking] 2011-07-21 10:50:42 PDT
Note: this happens only with the default theme.
Comment 11 Dão Gottwald [:dao] 2011-07-21 10:53:45 PDT
Please file a new bug.
Comment 12 Siddhartha Dugar [:sdrocking] 2011-07-21 11:00:12 PDT
(In reply to comment #11)
> Please file a new bug.

Done, bug 673164
Comment 13 Bruce A. Wittmeier 2011-07-22 08:11:44 PDT
Thanks, Dão.  Looks good - much cleaner.
Comment 14 bogas04 2011-08-14 03:29:13 PDT
Created attachment 552949 [details]
Must be implemented on Tab Scroll Buttons too
Comment 15 Siddhartha Dugar [:sdrocking] 2011-08-14 03:40:26 PDT
(In reply to bogas04 from comment #14)
> Created attachment 552949 [details]
> Must be implemented on Tab Scroll Buttons too

The remaining work is being tracked in Bug 580194
Comment 16 Dão Gottwald [:dao] 2011-09-08 01:56:10 PDT
*** Bug 586912 has been marked as a duplicate of this bug. ***
Comment 17 BoffinbraiN 2011-11-13 02:40:09 PST
The new inverted icons are a good idea, but the removal of the button styles for the navigation toolbar was a very bad one.  This has caused grief for many users and skin writers.  See why at http://forums.mozillazine.org/viewtopic.php?f=38&t=2357753

This bug actually does two completely separate things and should have been split in two.

We now have a bug tracker to revert the navigation bar change introduced here: bug #700972

Note You need to log in before you can comment on or make changes to this bug.