in native audio HTML5 player , throbber sudden apparition while loading perturbs the page layout

RESOLVED DUPLICATE of bug 619421

Status

()

RESOLVED DUPLICATE of bug 619421
9 years ago
8 years ago

People

(Reporter: anti-stress, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8

While it is possible to precise both height and width attributes in img or video tag to ensure that the page layout will not be broken while loading (for instance if my image or video is 100x200 i will set height="100" and width="200"), native firefox player for audio tag breaks the page layout while loading since the throbber shows up above the player (in a quite similar way to the video tag) which is weird since the audio player will not display any video !
Therefore there is no way to avoid that layout break by the firefox audio player considering that throbber implementation.

Please consider to change that implementation in order to avoid that the page layout constantly "jump" during loading. 

picture attached shows the layout perturbation.
On the left throbbers are shown while loading, on the right page is already loading

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 428844 [details]
the same page while loading / once loaded

here is the page shown http://libre-ouvert.toile-libre.org/?article8/
(Reporter)

Updated

9 years ago
OS: Linux → All
Hardware: x86 → All
(Reporter)

Comment 2

9 years ago
Maybe that the throbber could show up instead of the duration while loading and then be replaced with duration, since duration brings no information while loading (0:00)
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538084

Updated

8 years ago
Duplicate of bug: 619421
You need to log in before you can comment on or make changes to this bug.