[d2d] Very slow rendering and very slow scrolling on yahoo.com

RESOLVED DUPLICATE of bug 551350

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 551350
9 years ago
8 years ago

People

(Reporter: u88484, Unassigned)

Tracking

({perf, regression})

Trunk
x86
Windows 7
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

9 years ago
Load yahoo.com in the same tab.  It takes quite a while for the page to be displayed and then scrolling on the page is very, very slow.
Not reproducing for me. I wonder, what kind of graphics card and which driver version do you have? Perhaps I've been a bit enthusiastic in giving some DX 9 cards access to the D2D code. They might have some presentation issues or something. Considering your other 'rendering in one go' issue.

Also, I wonder if we should really use the regression keyword - It might make it more difficult to track real regressions (i.e. people not purposefully enabling experimental rendering modes and experiencing regressions?). Then again, I have no idea how else to mark regressions when running D2D.

Updated

9 years ago
Keywords: perf
(Reporter)

Comment 2

9 years ago
Windows 7
NVIDIA GeForce 7150M / nForce 630M
Drivers: 7.15.11.7967

I'm not sure or in the position to decide about the regression keyword but I added it for these bugs because this is a regression from previously having no issues that a new feature introduced.
I can't reproduce this issue here. Win 7 Pro x64, ATI 5870 with latest Catalyst 10.2 drivers. The GeForce 7150M is not a DX10 card, so it could be that fact alone. I believe that Windows 7 allows DX9 cards to emulate some DX10 features, but it's definitely not fast.
Blocks: 549116
No longer blocks: 527707
Summary: Very slow rendering and very slow scrolling on yahoo.com → [d2d] Very slow rendering and very slow scrolling on yahoo.com
(Reporter)

Comment 4

9 years ago
Created attachment 429768 [details]
Testcase

No where close to being reduced yet.
I can reproduce the problem on my DX9 nvidia card as well
(Reporter)

Comment 6

9 years ago
Created attachment 429777 [details]
Reduced testcase

Can you guys try this test case out?
Attachment #429768 - Attachment is obsolete: true
Works fine on my laptop DX 10 card.

Comment 8

9 years ago
I too was having sluggish scrolling under Windows 7 x64.  While it was sluggish before d2/dw it became worse when i turned them on. After trying to figure out the cause I finally was able to fix it on my system.  All I had to do was unlock the W7 Taskbar! I keep mine on the bottom and I autohide it.

Other little things that didn't work with it locked now work. Not a guarantee but it worked for me. 


Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100302 Minefield/3.7a3pre - Build ID: 20100302153901
Can't reproduce it on 8400GS. I think this is fault of DX9 graphic card.
Since D2D is not working (or it should not work) with DX9 cards.
Even I on a low budget graphic card can run D2D pretty good.
(Reporter)

Comment 10

9 years ago
Created attachment 432246 [details]
No issues - image is 4093 pixels

I'm attaching two test cases.  The first has a huge .png file that is 4093 pixels long.  This image does not cause a long page load or slow down scrolling.  The second test case will have an image that is 4097 pixels long and it dramatically slows down page load and scrolling is almost non-existent.

4096 pixels is the max texture size on DX9 cards whereas DX10 cards is 8192 (Per Bas)
(Reporter)

Comment 11

9 years ago
Created attachment 432247 [details]
Issues - image is 4097 pixels
Attachment #429777 - Attachment is obsolete: true
(Reporter)

Comment 12

9 years ago
Created attachment 432248 [details]
No issues - image is 4093 pixels
Attachment #432246 - Attachment is obsolete: true
(Reporter)

Comment 13

8 years ago
Bas, the fix that we talked about on IRC a few weeks ago, would that just be a small couple liner patch to up the values?
Yahoo looks much better now that bug 551350 landed in the latest hourly.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551350
You need to log in before you can comment on or make changes to this bug.