Last Comment Bug 549116 - (d2d) Enable Direct2D by default
(d2d)
: Enable Direct2D by default
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal with 17 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 553089 553788 555285 571447 605053 548985 549120 549661 549666 549911 550059 550684 550719 551295 551313 551350 552114 553269 553569 553603 553645 553852 555353 555388 555427 556193 557338 557372 557390 557391 558048 558339 558627 558708 559074 560050 561167 562038 565120 567295 570928 571046 571068 571235 571455 573236 573267 573641 574631 574670 575718 579921 584769 587316 587317 587318 587320 587325 587953 588604 588919 589806 590407 590568 591361 593812 596251 604321 612186 621495 622384 675497
Blocks: 569993 657129
  Show dependency treegraph
 
Reported: 2010-02-27 09:55 PST by Jeff Muizelaar [:jrmuizel]
Modified: 2012-06-22 08:16 PDT (History)
54 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jeff Muizelaar [:jrmuizel] 2010-02-27 09:55:17 PST
A tracking bug for enabling direct2d by default
Comment 1 Gary [:streetwolf] 2010-02-27 17:02:51 PST
Addblock Plus breaks 2d2.  Stylish does not.  I'm not really sure the difference between 2d2 and dw.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100227 Minefield/3.7a2pre - Build ID: 20100227151012
Comment 2 Bas Schouten (:bas.schouten) 2010-02-27 17:33:06 PST
If one's broken, then both are, since we read both the prefs at platform initialization time.
Comment 3 Jim Jeffery not reading bug-mail 1/2/11 2010-02-27 17:34:12 PST
With D2D & DW enabled go to www.google.com 

the page does not load fully - moving the cursor anywhere in the page reveals the rest of the page, i.e. the header at top etc...

Latest hourly trunk m-c, and I'm running at default DPI for the time being.
Comment 4 Bas Schouten (:bas.schouten) 2010-02-27 17:37:28 PST
(In reply to comment #3)
> With D2D & DW enabled go to www.google.com 
> 
> the page does not load fully - moving the cursor anywhere in the page reveals
> the rest of the page, i.e. the header at top etc...
> 
> Latest hourly trunk m-c, and I'm running at default DPI for the time being.

It's a new 'feature' from google I think. If it's of any comfort, I thought a couple of weeks ago that I broke it with D2D as well.
Comment 5 Jim Jeffery not reading bug-mail 1/2/11 2010-02-27 18:06:27 PST
With d2d and dw enabled visit:
http://www.intellicast.com/National/Radar/Current.aspx?location=default

the map does not fully render.  Clicking View Image will display the image.
While on that map - click the animate button - radar does not animate, again clicking view image will start the animation, but it seems its only showing 2 frames of the loop and it flashes badly doing that...
Comment 6 Peter Lairo 2010-02-28 03:19:11 PST
Related bug: bug 549115
Comment 7 Gary [:streetwolf] 2010-02-28 08:43:00 PST
When adding/disabling/uninstalling add-ons you may have to restart FF twice in order for d2d to work.  Same thing for changing Options. Changing/adding a style with Stylish sometimes breaks D2D.  A double restart is needed.  Then there are times D2D just breaks for unknown reasons.

Also there are a couple of themes that have separate optional extensions to
customize the themes more fully.  One is Chromifox Extreme which uses Chromifox
Companion extension.  The other is Strata40 which uses Stratabuddy extension. 
Both of these extensions (not the themes) break d2d.

Some themes break D2D where no amount of restarts will fix it.

Also images don't always download all the way.  You can have just a few lines
of the picture, half of the picture, etc.  

Oh yeah, the letters w and v display badly. Screenshot at http://img265.yfrog.com/img265/7688/capturetg.jpg
Comment 8 Gary [:streetwolf] 2010-02-28 08:44:22 PST
I suggest getting rid of bug 549115 and just use this one.
Comment 9 Danial Horton 2010-02-28 13:52:07 PST
Session Manager prevents Firefox from enabling D2D, tested with my extension loaded profile and verified in a clean profile.
Comment 10 Bas Schouten (:bas.schouten) 2010-02-28 13:54:20 PST
(In reply to comment #8)
> I suggest getting rid of bug 549115 and just use this one.

If it's to do with text, it's DirectWrite. If it's to do with other graphics, it's Direct2D. The two are hardly related :).
Comment 11 Gary [:streetwolf] 2010-02-28 14:14:05 PST
A development build for Addblock Plus works fine with D2D.  Here's the link to it:

[url=https://adblockplus.org/devbuilds/adblockplus/adblockplus-1.1.3+.2010022502.xpi]https://adblockplus.org/devbuilds/adblo ... 022502.xpi[/url]
Comment 13 Gary [:streetwolf] 2010-02-28 17:09:59 PST
Scrolling every now and then becomes quite sluggish.  No rhyme or reason to it but it always corrects itself.
Comment 14 Gary [:streetwolf] 2010-03-01 05:34:04 PST
I think the sluggish scrolling might be caused by using Full page zoom (not text only) on some of my sites.  It also seems to slow down d2d/dw as noticed in the sites I use to test it.
Comment 15 Shaun 2010-03-01 06:35:44 PST
Besides 0 and 6, what other integers trigger valid render modes in mozilla.widget.render-mode?
Comment 16 Danial Horton 2010-03-03 15:31:42 PST
https://www.mozdev.org/bugs/show_bug.cgi?id=22532

Could use some help from other testers, and anyone that knows why a extension would kill D2D.
Comment 17 Danial Horton 2010-03-21 23:20:14 PDT
I think i found an interesting issue,  after having switched to windows classic theme, firefox now crashes on image heavy sites while D2D is enabled.

however switching back to Aero glass/standard its fine.
Comment 18 Bill Gianopoulos [:WG9s] 2010-03-27 13:40:33 PDT
So, what is the intention here?  If it is to keep this as an over-rideable preference I am OK with that.  However, if this is to be the only option going forward at some point,k I have serious issues here.  I presume that most people see a noticeable improvement wit this enabled.  However, with my hardware, I see nothing the is measurably faster and many things that go form working reasonably fast ot unusably slow with this enabled.
Comment 19 Brian Carpenter [:geeknik] 2010-03-27 13:54:49 PDT
Bill, as far as I know, there will be an option in about:config to disable this, however, as of today, the Direct2D implementation is not complete, so judging it's performance today as opposed to in 3 months or 6 months, isn't really fair. =)
Comment 20 d 2010-03-27 14:01:21 PDT
Well, this does, in that case, raise the question about if we should check the performance somehow. If it can decide that things generally render slower with the "acceleration" on a certain users computer, it will automatically switch to the classic rendering.
Comment 21 Bill Gianopoulos [:WG9s] 2010-03-27 14:32:48 PDT
(In reply to comment #19)
> Bill, as far as I know, there will be an option in about:config to disable
> this, however, as of today, the Direct2D implementation is not complete, so
> judging it's performance today as opposed to in 3 months or 6 months, isn't
> really fair. =)

I fully realize that.  I was just hoping that if the situation does not improve for my configuration in the final product, I would still have the option of the old behavior.  I should also mention that the cases that are really painfully slow for me all involve the Adobe Flash Plug-in.  Perhaps this is a known issue?
Comment 22 Brian Carpenter [:geeknik] 2010-03-27 14:36:31 PDT
Yes, issues with D2D & Flash are documented and there are open bugs for it and other performance issues. =)
Comment 23 Bas Schouten (:bas.schouten) 2010-03-27 14:44:25 PDT
To answer Bill's questions:

We are aware of the windowless flash plugin performance issues. We actually have just discovered something we may be able to use to achieve considerable performance improvements here.

Furthermore, we realize for the foreseeable future there will be a considerable part of our userbase using hardware for which there could be performance regressions using Direct2D. For any initial 'switching on by default' we will define a 'whitelist' of hardware on which it will be switched on by default. On any hardware not on that list it will be disabled and classic GDI rendering will be used.

GDI rendering will not go away in the foreseeable future.
Comment 24 Danial Horton 2010-03-27 20:11:31 PDT
Fwiw, i've not noticed any performance issues while using flash 10.1, maybe try running that if your gfx hardware is amongst those supporting it.
Comment 25 cmtalbert 2010-03-29 13:44:06 PDT
(In reply to comment #20)
> Well, this does, in that case, raise the question about if we should check the
> performance somehow. If it can decide that things generally render slower with
> the "acceleration" on a certain users computer, it will automatically switch to
> the classic rendering.
We are working on a crowd-source testing add-on to help address this exact problem and to aid us with the hard data for building out the whitelist that Bas mentions in comment 23.

You can see some of the preliminary designs here: https://wiki.mozilla.org/Auto-tools/Projects/Halreftest.  

We are doing a preliminary roll-out for testing of the extension next week.  If anyone on this bug would like to participate in that, please send me an email and I'll add you to the list (ctalbert at mozilla dot com).  Put "Halreftest" in the subject so I can easily see them in the deluge of email I get.  Thanks!
Comment 26 Daniel Kirsch 2010-05-10 00:50:28 PDT
I suggest having a setting in the preferences dialog in the final release to make it easy for any user to enable/disable d2d. At least in the "advanced" settings. This way people can try to enable and try d2d even if their hardware is not on the whitelist or can disable it if their configuration causes problems.
Comment 27 Wes Kocher (:KWierso) 2010-05-26 21:48:56 PDT
From what I've seen, it seems like using the Restart button from the new addons manager will restart without D2D enabled, regardless of which extensions are enabled.

Manually shutting down and starting up Firefox with the same extensions enabled starts it with D2D working.

Is there already a bug for this? Anyone else see it?
Comment 28 Leon Sorokin 2010-06-28 14:11:43 PDT
requesting Bug 574976 be added to the dependency list. 0_o
Comment 29 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-18 07:35:33 PDT
Turned on in nightlies: http://hg.mozilla.org/mozilla-central/rev/42545f8d4b10
Comment 30 Mike Beltzner [:beltzner, not reading bugmail] 2010-09-13 06:40:02 PDT
Should this bug be marked FIXED?
Comment 31 Helder "Lthere" Magalhães 2010-10-17 01:53:39 PDT
(In reply to comment #30)
> Should this bug be marked FIXED?

IMHO, yes. Conceptually it is fixed.

Nevertheless, I'm guessing that, while this issue is being used as tracker bug (and I guess that it is, currently), that's a good reason not to mark it as fixed yet (visibility decreases considerably, as most searches/filters only return open bugs), so I'd vote for leaving it open: at least while the most important set of issues depends on aren't simply "forgotten". ;-)
Comment 32 Matt Woodrow (:mattwoodrow) 2011-10-06 20:13:22 PDT
Closing this since Direct2D is enabled by default now.

Note You need to log in before you can comment on or make changes to this bug.