Closed Bug 549044 Opened 12 years ago Closed 3 years ago

Account Wizard says "Password wrong", although it's correct (various situations)

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 555448

People

(Reporter: BenB, Unassigned)

Details

(Keywords: polish, Whiteboard: [has l10n impact])

At the end of the Account Wizard process, when you click Create Account, and we try to verify the login process and username/password, if the login fails for whatever reason, we just say "please check your password". However, the login may have failed for many other reasons.

For example, we may have guessed the username form wrong, or the advertised login mechanism doesn't work (server fault), or the server allows only one login every 15 minutes (one very big email provider does that), or any number of other reasons. I encountered such situations myself. In fact, most of the time when I saw "password wrong, please check", the password was actually correct and something else failed. We are leading the user down the wrong path - that's the worst possible kind of UI.

At the very minimum, we need to show the error message that the server gave - we already do that when login fails in the main window during POP Get Mail / IMAP login, and the server error msg is just as important during account setup. We need to give the user all information we have about the error and its possible / likely reasons.
We must not assume or imply that the password is wrong unless we know it is wrong (and we typically don't know that).
Keywords: polish
Whiteboard: [has l10n impact]
20100910
Within bugzilla, looked up for: Mail Account Setup Password
-----------------------------------------------------------------------

Using Thunderbird: 3.0.6

At the adding of a new Mail Account and the end of the setup process within the window "Mail Account Setup" I touched the button "Create Account", than I have got to messages: 

"Username or password invalid." and
"Configuration could not be verified - is the username or password wrong?"

The Email address was correct.

After several tries, I changed the provider password for that mailaccount.

Than, the creation process was successful.

Problem was: The password contained a bracket: "]"

Now there are two possibilities:

Wether the server dosn´t allow that sign, at the login, nor thunderbird processes the password incorrectly. 

I think my provider does it right, and thunderbird does the flaw.

Best regards,
TOM
Additional Comment: to 549044

Excuse me, my provider recommends to abandon on special characters whithin passwords.

TOM
add me to the Interested Parties on this.

Since switching to Thunderbird 6.0 getting a new account set up has been pretty dicey.  As noted above: the account credentials are rejected.

Note that any properly configured service will not say why credentials are rejected, just that they are rejected, e.g. "Invalid Logon".  this makes hacking harder and is the right thing to do.

Response then is to double check every field in the logon credentials against the instructions.

Now with T-Bird 6.0 I did this over and over. When I set T-Bird on "safe mode" it snapped in, First try.

Remember in the Create Account Sequence you have to take the "MANUAL" option at the end of the automatic search and set the UserID (not the e/mail address) the UserID for the server in the space provided.

the service i was using was CoreComm STARTTLS
Client: Win7(64)Home Premimum. plugins: Lightning; ENIGMAIL.
Severity: major → normal

FIXED as bug 555448.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555448
You need to log in before you can comment on or make changes to this bug.