crashes related to nsPluginStreamListenerPeer::mLocalCachedFile [@ nsPluginStreamListenerPeer::~nsPluginStreamListenerPeer() ] [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsCOMPtr<nsIAtom>::operator=(nsCOMPtr<nsIAtom> const&) | nsPluginStreamLis

RESOLVED FIXED

Status

()

Core
Plug-ins
P1
critical
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Aaron, Unassigned)

Tracking

({crash, topcrash})

Trunk
x86
Windows 7
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100227 Minefield/3.7a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100227 Minefield/3.7a2pre

nsPluginStreamListenerPeer  is crashing and closing the browser out somethimes in Mozilla Minefield 3.7a2pre..  I don't know what is the cause of it.  But the Site I was on that it crashed in is password protected so I would not be able to put the website address up.  But I can put the crash report up and here it is

http://crash-stats.mozilla.com/report/index/72a73e5f-a7f5-4c86-8e74-a7f722100227

Reproducible: Sometimes

Steps to Reproduce:
1.The site I was on is password protected so I would not be able to put any reproducing steps here.
2.
3.
Actual Results:  
All I did was click on a link in a forum and it just closed the brouser out with the Mozzilla minefield crashed box and sent a report to Mozilla.

It doesn't do it all the time.

Expected Results:  
When I click on a link in a forum it should not crash the browser

I am using the summer clouds theme.  Build platform target i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
(Reporter)

Updated

8 years ago
Keywords: crash
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Priority: -- → P1
Yep, two new topcrashes appeared in today's nightly builds, both related to the mLocalCachedFile member of nsPluginStreamListenerPeer:

http://crash-stats.mozilla.com/report/list?product=Firefox&branch=1.9.3&platform=windows&build_id=20100227035329&query_search=signature&query_type=exact&query=&date=&range_value=31&range_unit=days&process_type=all&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&signature=nsPluginStreamListenerPeer%3A%3A~nsPluginStreamListenerPeer%28%29

http://crash-stats.mozilla.com/report/list?product=Firefox&branch=1.9.3&platform=windows&build_id=20100227035329&query_search=signature&query_type=exact&query=&date=&range_value=31&range_unit=days&process_type=all&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&signature=nsCOMPtr_base%3A%3Aassign_with_AddRef%28nsISupports*%29%20|%20nsCOMPtr%3CnsIAtom%3E%3A%3Aoperator%3D%28nsCOMPtr%3CnsIAtom%3E%20const%26%29%20|%20nsPluginStreamListenerPeer%3A%3ASetupPluginCacheFile%28nsIChannel*%29
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
Keywords: topcrash
Product: Firefox → Core
QA Contact: general → plugins
Summary: nsPluginStreamListenerPeer Crash → nsPluginStreamLis crashes related to nsPluginStreamListenerPeer::mLocalCachedFile [@ nsPluginStreamListenerPeer::~nsPluginStreamListenerPeer() ] [@ nsCOMPtr_base::assign_with_AddRef(nsISupports*) | nsCOMPtr<nsIAtom>::operator=(nsCOMPtr<nsIAtom> const&) |

Comment 2

8 years ago
Fixed by backing out bug 548217, http://hg.mozilla.org/mozilla-central/rev/6119cab79ff7
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 548543
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsPluginStreamListenerPeer::~nsPluginStreamListenerPeer() ]
You need to log in before you can comment on or make changes to this bug.