Closed Bug 549589 Opened 10 years ago Closed 10 years ago

Implement new location bar and search bar style

Categories

(Firefox :: Theme, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 3.7a3

People

(Reporter: dao, Assigned: dao)

References

Details

Attachments

(1 file, 3 obsolete files)

Attached patch patch (obsolete) — Splinter Review
No description provided.
Attachment #429700 - Flags: review?(rflint)
Attached patch patch (obsolete) — Splinter Review
small icons mode and emptytext color fixed
Attachment #429700 - Attachment is obsolete: true
Attachment #429715 - Flags: review?(rflint)
Attachment #429700 - Flags: review?(rflint)
Attached patch patchSplinter Review
the previous patch unintentionally removed a line break...
Attachment #429715 - Attachment is obsolete: true
Attachment #429719 - Flags: review?(rflint)
Attachment #429715 - Flags: review?(rflint)
Attachment #429719 - Flags: review?(rflint) → review+
http://hg.mozilla.org/mozilla-central/rev/81a7e5da3c4a
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a3
These bugs are really confusing me because the summary and comment 0 are all very vague.  Comment 0 should describe exactly what the changes will entail.

The summary of this bug is "Implement new location bar and search bar style" which to me would be every single change that is displayed in the mockups that relate to the location and search bars.  Where is the star button that is shown to be to the left of the site identity button?  I see there is a separate bug for combining the stop/go/refresh buttons so I can understand that the work for that will be done in that bug but I only know that because I hunted down that information before completing my comment here.
Depends on: 549820
(In reply to comment #4)
> The summary of this bug is "Implement new location bar and search bar style"
> which to me would be every single change that is displayed in the mockups that
> relate to the location and search bars.

No. It's filed in the Theme component and as such it covers theme changes.
Please provide a description and/or screenshot-mockup of what this bug is supposed to fix. Slipping in fixes without providing this information is anti-transparent and seems like changes, that may be for the worse, are being slipped-in "under the radar".
Those details were already disclosed:
https://wiki.mozilla.org/Firefox/4.0_Windows_Theme_Mockups

Half of the internet saw it by now.
Minor problem with this change.  If the site is https the location bar increases a pixel or two in height.  Going to a http site reverts it back to normal.  Also the buttons change in height also.
I'm not seeing this. Please file a bug including screenshots?
Attached image Screenshot (obsolete) —
Here's a screenshot of this ugliness
(In reply to comment #8)
> Minor problem with this change.  If the site is https the location bar
> increases a pixel or two in height.  Going to a http site reverts it back to
> normal.  Also the buttons change in height also.

Works for me. Have you checked for some installed extension that can cause this problem?
I created a brand new profile and still have the problem.  I file a bug with screenshots.
Depends on: 549898
Depends on: 550333
Duplicate of this bug: 462982
Attachment #430015 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.