Closed Bug 549814 Opened 10 years ago Closed 10 years ago

Internal error when using login fields in header/footer after visiting token.cgi URL

Categories

(Bugzilla :: User Accounts, defect)

3.4.5
defect
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 3.4

People

(Reporter: reed, Assigned: reed)

References

Details

Attachments

(1 file)

Dave and I have been seeing complaints to bugzilla-admin@ about people getting internal errors after creating their account. I tracked it down to the login fields in the header/footer trying to submit to token.cgi, which just causes an internal error since the token no longer exists.

My fix is to just use index.cgi as the form post URL if the page is token.cgi.
Attachment #429944 - Flags: review?(mkanat)
Dupe of bug 398879. It's the same root cause.
Duplicate of this bug: 398879
Comment on attachment 429944 [details] [diff] [review]
patch - v1 (untested)

Works and is a good solution.
Attachment #429944 - Flags: review?(mkanat) → review+
Flags: approval3.6+
Flags: approval3.4+
Flags: approval+
Duplicate of this bug: 555318
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/account/auth/login-small.html.tmpl
Committed revision 7082.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.6/
modified template/en/default/account/auth/login-small.html.tmpl
Committed revision 7045.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.4/
modified template/en/default/account/auth/login-small.html.tmpl
Committed revision 6753.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 577453
You need to log in before you can comment on or make changes to this bug.