Forward and back icons don't work

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
9 years ago

People

(Reporter: bert4545, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Build Identifier: 

I don't understand how to answer some of the above boxes. The forward and back icons are always greyed out on the toolbar.  Next and Previous only go to unread messages.  I want to go through my read messages to delete those I don't want to keep. Other people have the same problem (see mozilla forum)

Reproducible: Always
Created attachment 430261 [details]
Previous, back, forward, next buttons

You mean those buttons in the picture?
Back and forward are history buttons. After you have been to an email and left it, clicking back will take you back. Forward is the reverse.

Whats the link to the specific forum thread you are referring to?

Are all your emails missing? Can you attach a picture to better show the problem?
(Reporter)

Comment 2

9 years ago
Yes, Matt, those are the icons, though yours look a little bit different from mine.  Next and Previous only go to unread messages.  On the inbox page (or any other page) the forwards and back icons are greyed out and do nothing.  When I open an email, they are also greyed out.  But a moment ago I found I could go back two or three messages (something I had never noticed before)and then forwards back to where I started from.  But when I tried to reproduce that (because I coldn't believe I'd never noticed it before) I couldn't - every email I opened had the icons greyed out.  Perhaps I need to know which version of TB I have.  On Windows you don't have to leave an email - you can click forward or back and just go to the next email, read or unread.
(Reporter)

Comment 3

9 years ago
The link to my question on the forum is:
http://forums.mozillazine.org/viewtopic.php?f=39&t=1770085
which contains a link to somebody else asking the same question.  I admit two people complaining is not a lot.  Maybe other people don't want to register on the forum or on bugzilla and just put up with it.
I was on linux. For you the buttons are probably blue.

I just use the keyboard up and down keys or click on the email. The "Buttons!" add on mentioned has been updated to work with Thunderbird 3 now. This appears to be what you want. See if it fixes the problem.

https://addons.mozilla.org/en-US/thunderbird/addon/106
Tried it. Seems to be what you are looking for. On my computer, they look the same as next and previous buttons with an exclamation point on the end.
(Reporter)

Comment 6

9 years ago
Thank you, Matt.  I have got the icons on my toolbar.  It seems odd that whoever did this thought using the exclamation mark to differentiate the two functions was a good idea, but grateful for small mercies.  Once I have used the next! or previous! buttons, the forwards and back buttons are activated, but only allow you to go forward or back to where you started - which is OK
I hadn't used the up and down arrows since I used Windows at work.  They only work when you are in one of the folder (files?) Inbox, sent Items.  I need to have the email open so I know what it's about, then I want to go to the next email (or previous) and the arrows don't do that.
Sounds like its working for you so I am going to mark as "resolved". If this isn't resolved for you, just mark "reopened".

Marked "incomplete" because it was more of a support request.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.