[kitsune] Concat and Minify JS and CSS

VERIFIED FIXED in 2.0

Status

support.mozilla.org
Knowledge Base Software
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: jsocol, Assigned: jsocol)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
We should look at something like one of the following:

http://github.com/mintchaos/django_compressor#readme
http://code.google.com/p/django-compress/wiki/Usage
AMO's YUICompressor-based app.

We should give these (and possibly other options) a quick once over and see which one makes us happiest.
(Assignee)

Comment 1

8 years ago
(For the record, so far I like the first one the most, because it keeps all the JS and CSS exclusively in the templates, with just a couple wrappers.)
(Assignee)

Comment 2

8 years ago
AMO's may be the best option, given that we're using Jinja. The other options in comment 0 are pretty Django-template specific.
(Assignee)

Updated

8 years ago
Target Milestone: --- → 2.0
(Assignee)

Updated

8 years ago
Duplicate of this bug: 556662
(Assignee)

Comment 4

8 years ago
This was unassigned for a while because it bounced around between me and Paul.

I got the app out of AMO and put it up and http://github.com/jsocol/jingo-minify

This patch is based on that:
http://github.com/jsocol/kitsune/commit/f159b8f25ea78c38cc7e60fae6004ccb5e1273c6
Assignee: nobody → james
All works except results.html needs to be updated with the new css value, on line 4.
(Assignee)

Comment 7

8 years ago
Merged to development with the changes from comment 6.

http://github.com/jsocol/kitsune/commit/1c6f3dc864e9e4402e08786e3755a23744bc473f
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Created attachment 439482 [details]
Post-fix screenshot, showing Firebug's "Net," "All" panels
Verified FIXED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.