Closed Bug 550659 Opened 10 years ago Closed 8 years ago

Using a symlinked greDir fails to launch application from nsXULStub

Categories

(Toolkit Graveyard :: XULRunner, defect)

1.9.2 Branch
x86
Linux
defect
Not set

Tracking

(status1.9.2 beta4-fixed)

RESOLVED FIXED
mozilla8
Tracking Status
status1.9.2 --- beta4-fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file, 2 obsolete files)

+++ This bug was initially created as a clone of Bug #530196 +++

> A xulrunner-stub based application where the GRE (xulrunner) is on a symlinked
> folder will fail to launch. I have not been able to find the exact place the
> failure occurs. But I have a simple patch to fix the problem. The patch simply 
> resolves the symlink in the stub before initializing XPCOM.

This still applies in some cases where the GRE directory is determined in another place in the code path (e.g. $APP_DIR/xulrunner exists). Moving the symlink resolution to be unconditional should solve the issue.

Note the symlinked GRE issue doesn't exist in 1.9.1, so this is a regression in 1.9.2. I don't know if there is a bug tracking this particular issue.
Attached patch Patch (obsolete) — Splinter Review
(the patch is against 1.9.2)
Assignee: nobody → mh+mozilla
Attachment #430808 - Flags: review?(benjamin)
(In reply to comment #0)
> Note the symlinked GRE issue doesn't exist in 1.9.1, so this is a regression in
> 1.9.2. I don't know if there is a bug tracking this particular issue.

It also seem to have more impact than the stub problem. It looks like it induces problems with symlinked profiles and symlinked extensions.
A real fix for the underlying issue is in bug 551152, but I think the symlink resolution should be kept anyways, and moved as done by the attached patch.
tracking-fennec: 1.0+ → ---
Comment on attachment 430808 [details] [diff] [review]
Patch

I think this bug got obsoleted by the gre-finding removal, but in any case the code has changed in ways that make the patch unusable.
Attachment #430808 - Flags: review?(benjamin)
bug 551152 has been fixed, but I still thought the symbolic link should be resolved, though I'm not sure why, now. Probably for components registration (xxpti.dat used to contain full paths).

The new code after the gre-finding removal doesn't do the symbolic link resolution anymore, so this is a patch that adds it back, but I'm not sure we need that now.
Attachment #430808 - Attachment is obsolete: true
Attachment #430809 - Attachment is obsolete: true
Attachment #525965 - Flags: review?(benjamin)
Attachment #525965 - Flags: review?(benjamin) → review+
http://hg.mozilla.org/mozilla-central/rev/b774154497e1
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
Depends on: 690679
No longer depends on: 690679
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.