Closed Bug 550666 Opened 12 years ago Closed 12 years ago

Builds broken in memory/mozalloc/mozalloc.cpp

Categories

(Core :: XPCOM, defect)

All
FreeBSD
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9.3a5

People

(Reporter: mpk, Assigned: mpk)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

Since the fix for bug 441324 landed, builds for all mozilla apps on FreeBSD
(NetBSD and OpenBSD probably too) fail quite early with the following error:

...
gmake[6]: Entering directory `/work/build/browser/memory/mozalloc'
mozalloc.cpp
mozalloc_oom.cpp
/work/src/mozilla/memory/mozalloc/mozalloc.cpp:
    In function 'void* moz_xvalloc(size_t)':
/work/src/mozilla/memory/mozalloc/mozalloc.cpp:196:
    error: 'valloc' was not declared in this scope
/work/src/mozilla/memory/mozalloc/mozalloc.cpp:
    In function 'void* moz_valloc(size_t)':
/work/src/mozilla/memory/mozalloc/mozalloc.cpp:206:
    error: 'valloc' was not declared in this scope
gmake[6]: *** [mozalloc.o] Error 1
gmake[6]: Leaving directory `/work/build/browser/memory/mozalloc'
...

*BSD defines valloc in unistd.h (see http://man.freebsd.org/valloc)
Attached patch patch v2 (mozilla-central) (obsolete) — Splinter Review
Unconditionally including unistd.h would cause problems on Windows.
This patch includes <unistd.h> only if XP_UNIX is defined.
Assignee: nobody → bugmail
Attachment #430814 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Flags: in-testsuite-
Keywords: regression
Attachment #430826 - Flags: review?(benjamin)
Duplicate of this bug: 556048
Attachment #430826 - Flags: review?(benjamin) → review+
Keywords: checkin-needed
Unfortunately it appears this has bitrotted.  Can you update the patch Marco?
Keywords: checkin-needed
Oops, it looks like rev bbbb2d668d0d (bug 550401) touched that file last thursday.
Attachment #430826 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/1a6aac2558e4
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
You need to log in before you can comment on or make changes to this bug.