:hover attached to an element does not work while mousing over that element

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
P2
major
VERIFIED FIXED
17 years ago
15 years ago

People

(Reporter: Nisheeth Ranjan, Assigned: David Hyatt)

Tracking

({css2, regression})

Trunk
css2, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm need info])

(Reporter)

Description

17 years ago
This is a regression and we should try to fix it for rtm.  A potential fix is to
back out joki's changes for enabling hierarchical hover notifications (see bug
5693).

Note from ekrock: CSS1 :hover property is high-profile standards compliance. It
has been working in the pre-release builds and is highly anticipated by the
content community. There is also a significant amount of content on the web
already that uses :hover as it is supported by IE 4.0 Win and above. We also
have marketing demos that depend upon the simple case of :hover on an individual
element working correctly.

In this bug, we are not proposing to fix the hierarchical propagation of hover
events up the tree (see bug 5693). We are only proposing to fix the recent
regression of breaking simple hover on a single element that was broken by
joki's checkin. joki added a pref that turns off his checked-in code, but the
pref turned out to turn off too much and break the simple case of hover on a
single element.
(Reporter)

Comment 1

17 years ago
nisheeth and ekrock: marking rtm, regression, css1. Setting P2 as this is
high-profile standards compliance.
Keywords: css1, regression, rtm
Priority: P3 → P2
Whiteboard: [rtm need info]

Comment 2

17 years ago
:hover is css2 not css1.
css1 -> css2
Keywords: css1 → css2
Note that only fixing this (and not the hierarchical hover notifications stuff)
will mean even simple cases like this:

   <a href="">  <img src="" alt="">  </a>

...fail. This is one reason why bug 5693 is so important.
(Reporter)

Comment 5

17 years ago
Hyatt has a fix for this.  Re-assigning to him.
Assignee: joki → hyatt
PDT, please accept this into the branch once we get review & super-review:

1) this is a regression of functionality that worked earlier
2) IE for Windows and Mac both support this, and there's already a significant 
amount of content out on the web that uses this as a result
3) the content community is watching this one *extremely* closely and will be 
furious if we break even basic :hover in RTM when it was working in previous 
Mozilla builds--this is some of the highest-profile CSS standards-compliance 
there is
4) we demo the use of this functionality in our standard marketing demos for 
Netscape 6 
(Assignee)

Comment 7

17 years ago
Everything is in place over in 5693.  The patch is actually over there.  Please 
don't make me move it all over here.  Last patch in 5693 fixes this bug.  
r=saari, and a=waterson.

This bug is critically important, since it fixes basic :hover functionality that 
had been working for over a year (and only recently regressed).  We have to get 
this fixed for RTM.
Status: NEW → ASSIGNED

Comment 8

17 years ago
*** Bug 55297 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 55297 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
I think there need to improvement in the midair-collision detection.
Suggest: OS=ALL, Plattform=ALL.

Updated

17 years ago
Severity: normal → major
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Updated

17 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

17 years ago
Fixed by patch to 5693.
*** Bug 56360 has been marked as a duplicate of this bug. ***
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
this has been fixed for some time
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.