mouse wheel events sent to acrobat reader tab in background after loading a PDF

RESOLVED DUPLICATE of bug 541368

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 541368
8 years ago
8 years ago

People

(Reporter: Niklas Beisert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I select multiple documents on some page for later reading using the middle mouse button (open in new tab; "when I open a link in a new tab, switch to it immediately" disabled or browser.tabs.loadInBackgroud:true; browser.tabs.opentabfor.middleclick:true; all default behaviour). If one of the documents is a PDF and after it has finished loading, the mouse wheel does not work anymore on the active tab from where the documents were selected. Instead the PDF in an invisible tab is scrolled.

Reproducible: Always

Steps to Reproduce:
1. open a PDF in a background tab using middle (wheel) mouse button (e.g. the link "donation form" at the bottom of http://www.mozilla.org/foundation/donate.html ).
2. wait till PDF has finished loading
3. move the mouse wheel
Actual Results:  
active tab is not scrolled. instead PDF in background is scrolled

Expected Results:  
active tab should be scrolled.

This happens only after the PDF has finished loading and the Acrobat Reader plugin activates.

It may also be wrong behaviour of the Adobe Acrobat plugin (File: nppdf32.dll, Version: 8.2.0.81, Adobe PDF Plug-In For Firefox and Netscape)?

Potentially related: Bug 223575, Bug 506866, Bug 78414
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541368
You need to log in before you can comment on or make changes to this bug.