Closed Bug 550847 Opened 10 years ago Closed 10 years ago

Firefox should support Matroska (MKV) with theora+vorbis

Categories

(Core :: Audio/Video, enhancement)

x86
Linux
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 476727

People

(Reporter: rom, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

OGG is used for many theora videos because it is the default container. Definitely, firefox must (and does) support it.

But MKV is better than OGG on almost every point.
It supports streaming very well too.

Overhead is huge in OGG (~1%), while near 0% in mkv (that's not a lot, but for streaming, if bitrate can be reduced without any quality lost, that's better).

But for web, above all, OGG does not support chapters at all. So for chaptering a video on a website, we have to write chapters in HTML and use JavaScript for seeking. Problem : when you download the video to keep it on your disk, and play it with your player, you don't have chapters anymore.
So it asks some work for managing chapters using Javascript, and they are lost when downloading video. It would be easier to just put the chapters in MKV, that Firefox can manage them, when you download the video, any player would be able to use chapters (VLC for example).

I understand (and agree) that Firefox won't support h264 (for patents reasons), but for the container, Matroska is free just like ogg, there is no reason to not support it, no?

Reproducible: Always
Looks like this was requested before and was marked wontfix with the option to reconsider later.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Resolution: --- → DUPLICATE
Duplicate of bug: 476727
You need to log in before you can comment on or make changes to this bug.