Support the Matroska (MKV) container

RESOLVED WONTFIX

Status

()

Core
Audio/Video
RESOLVED WONTFIX
9 years ago
5 months ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
I'm not exactly sure how Matroska compares to Ogg but people seem to have fewer bad things to say about it (better seeking support and more codec agnostic) and it seems more popular for video content on the internet.

The Matroska website claims to have a bsd licensed playback library but I wasn't able to find it...

Comment 1

9 years ago
> it seems more popular for video content on the internet

I've never seen a Matroska container anywhere. Where do people use it?
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> > it seems more popular for video content on the internet
> 
> I've never seen a Matroska container anywhere. Where do people use it?

It's not the most legitimate place, but most of the movies at http://thepiratebay.org/top/207 use mkv and it's now a supported container in Divx Plus HD (http://investors.divx.com/releasedetail.cfm?ReleaseID=357904 and
http://www.zatznotfunny.com/2008-06/divx-to-support-the-mkv-video-format/)

Comment 3

9 years ago
I suspect mkv is popular at thepiratebay since it's good for ripping dvd's. It can carry the menu's, chapters, alternate tracks, etc over.

Is there any Matroska content that uses Theora and Vorbis as the codecs though? Even if we support Matroska we couldn't play back any of those examples since they use Divx as the codec.
(Reporter)

Comment 4

9 years ago
I don't know of any specific Theora/Vorbis content but the container does support those codecs. (http://matroska.org/technical/specs/codecid/index.html).

The value of this really depends on how much, if any, pain Ogg is giving us.

Comment 5

9 years ago
And how much pain a switch would be. We'd no longer be able to play back videos from archive.org, Wikimedia and other users of .ogg. Unless we supported both of course.
(Reporter)

Comment 6

9 years ago
Yeah, I certainly don't think we should replace ogg support, the Matroska support would be an additional supported container.
We don't have plans to do this at the moment, we may consider it at a later stage. We can reopen or recreate this bug if we decide to implement support for MKV later.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 550110

Updated

8 years ago
Duplicate of this bug: 550847

Updated

8 years ago
OS: Mac OS X → All
Hardware: x86 → All
Summary: Support the Matroska container → Support the Matroska (MKV) container

Updated

5 months ago
See Also: → bug 1422891
You need to log in before you can comment on or make changes to this bug.