No transparencies for xul:panel elements in Linux

RESOLVED DUPLICATE of bug 408284

Status

()

RESOLVED DUPLICATE of bug 408284
9 years ago
8 years ago

People

(Reporter: min.huang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091216 Iceweasel/3.5.8 (like Firefox/3.5.8)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091216 Iceweasel/3.5.8 (like Firefox/3.5.8)

No transparencies for xul:panel elements.  The opacity and background-color: transparent css styles are apparently ignored.

(I will make an attachment for this in a bit)

Reproducible: Always

Steps to Reproduce:
1.  Install the test extension on a Linux machine
2.  Click on Panel Test -> Open Panel
3.  A xul panel appears
Actual Results:  
The xul panel appears and is not transparent

Expected Results:  
The xul panel appears and is transparent

This happens for me on Linux; doesn't happen for me on Windows and OSX.

I notice the Ubiquity extension uses a XUL panel but doesn't offer transparencies in Linux.  Installing Ubiquity on a Windows or OSX machine offers transparencies for the panel.
(Reporter)

Comment 1

9 years ago
Created attachment 431293 [details]
An extension that opens up a xul panel and tries to be transparent.

Please ignore the name of the extension.  This is just a test extension that shows transparencies on OSX and Windows but not Linux.

Comment 2

8 years ago
See also bug 408284
Component: General → Widget: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Blocks: 575735
The Inspector (landed in 3.7a+) uses a panel with transparency for its highlighter. This is going to block this or we'll need to come up with an alternative for linux.

cc'ing Enn.
Depends on: 408284

Updated

8 years ago
No longer blocks: 575735
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 408284
Resolution: --- → DUPLICATE
Duplicate of bug: 408284
You need to log in before you can comment on or make changes to this bug.