Closed Bug 551200 Opened 12 years ago Closed 8 years ago

Move table of contents into the sidebar in the wiki.mozilla.org theme

Categories

(Websites :: wiki.mozilla.org, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 651896

People

(Reporter: dietrich, Unassigned)

Details

Attachments

(1 file)

The TOC is currently above content, which means that it pushes most of the page content out of the default view.

We should modify the theme to move the TOC into the sidebar, or off to one side with content flowing around it.
Dietrich,

Isn't this more of a webdev thing? :) Can you provide some more info, a link maybe so we can better understand what you're looking for?
switching to webdev. screenshot coming.
Assignee: server-ops → nobody
Component: Server Operations → Webdev
QA Contact: mrz → webdev
Attached image screenshot
note how the TOC takes up the entire page. having it off to the right, with content flowing around it would be better.
For what it's worth, this could look not-so-great on wiki pages with long and wide tables of content. For example: 

https://wiki.mozilla.org/Partnering:Projects:BYOB
https://wiki.mozilla.org/User:LesOrchard/BandwagonAPI
Component: Webdev → wiki.mozilla.org
Product: mozilla.org → Websites
QA Contact: webdev → wiki-mozilla-org
Moving table or making it float(or make content float around it) doesn't seem like a good idea to me. What we could do is to add a small button inside it(or somewhere besides) that could hide/show it.
Adding a button means requiring users to manually work around the problem every time they go to a page that has it.  Why doesn't moving the table or making it float seem like a good idea to you?
I don't like what it looks like, though it might make sense to do that as it would push the content above the fold, for sure.

http://i.imm.io/8rz5.png
Mine is just another opinion, of course, but that screenshot actually looks a lot better to me than what I imagine it would look like with a whole bunch of empty space next to the table of contents! :-)
The way Wikipedia does it is by having the TOC before the first section header (but after any introductory content), which I think works well. They also have a show/hide button, should you need to use it.

And you can also use the __TOC__ constant on Wikipedia to put the TOC where you think it would better fit, on a case-by-case basis. IIRC, this does not currently work on wiki.m.o, which I believe is a bug in the style, not the wiki code.
The TwentyTen skin for MediaWiki (a port from the WordPress theme of the same name) now has the page ToC in the sidebar.  See https://github.com/samwilson/mediawiki_twentyten
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 651896
You need to log in before you can comment on or make changes to this bug.