[d2d/dw] Animated GIF causes screen corruption with d2d/dw enabled.

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: streetwolf, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100309 Minefield/3.7a3pre Firefox/3.6
Build Identifier: 20100309041426

Go to the site in the URL.  Start scrolling down until you get to the Radar loop GIF on the right side.  Wait until the GIF completes.  For me the GIF just disappears. Then start scrolling down again.

Reproducible: Always

Steps to Reproduce:
1. Go to URL provided.  Make sure d2d/dw is enabled
2. Scroll to the Radar loop GIF.  Wait till it completes.
3.
Actual Results:  
After GIF stops and disappears further scrolling causes screen corruption

Expected Results:  
GIF should probably be looping and scrolling shouldn't cause screen corruption.
Reporter

Updated

9 years ago
Blocks: 527707
Version: unspecified → Trunk
Blocks: d2d
No longer blocks: 527707
Interestingly enough the GIF is also showing corruption in normal firefox, although in that case it doesn't break the rest of the page! Requires further investigation.
Reporter

Comment 2

9 years ago
Problem seems to be fixed in one of the latest hourlys.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100312 Minefield/3.7a3pre - Build ID: 20100312072530
Reporter

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.