Archive button not always working when clicked - returns "thunderbird cannot create a folder because it already exists"

NEW
Unassigned

Status

Thunderbird
Message Reader UI
--
minor
9 years ago
3 years ago

People

(Reporter: sparrow, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme)

Attachments

(1 attachment)

134 bytes, application/octet-stream
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729) FirePHP/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

The "Archive" button is not always working when clicked. Sometimes you need to click it twice! to have the message archived (as if no focus issue)

Reproducible: Sometimes

Steps to Reproduce:
1. click the archive button once
2. message still is not archived
3. click the archive button for the second time
4. message is successfully archived


Expected Results:  
button should work for the first click

Updated

9 years ago
Component: General → Message Reader UI
QA Contact: general → message-reader
Any error messages in Tools -> Error console when this happens ?

Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)

Does this happens on particular messages or on random ones ?
(Reporter)

Comment 2

8 years ago
This happens on random messages, but probably only on IMAP accounts. Most often when I switch back from a different application and then try to archive a mail. No errors on error console...

Comment 3

8 years ago
I can confirm that this happens for me as well. In my situation I only have one account configured, which happens to be IMAP (Dovecot IMAP 1.0.10-1ubuntu5.2). Invariably, the first time I archive an email after starting up Thunderbird (3.0.4), it doesn't apparently do anything.

No output appears in Tools -> Error console when the archive fail. The process I've used is.
1. Start Thunderbird
2. Select Inbox
3. Open Error Console
4. Clear messages
5. Archive message (nothing apparently happens)
6. Check Error Console (no messages generated).
7. Attempt archive again.
8. Check Error Console (lots of messages about unknown descriptors and unknown properties, etc. that seem to be specific to displaying some messages in the message pane).

At this point archiving always works until Thunderbird is restarted.

I can also confirm that this behaviour persists when running Thunderbird in Safe mode.

Comment 4

8 years ago
I've discovered that the issue in my case was an IMAP server that didn't support folders that contained messages and sub-folders. The IMAP server is Dovecot configured to use mbox format.

On the first attempt to archive a message with Thunderbird 3.1 Beta 2, a notification would pop up saying something about the server not supporting "inferior folders". I might have the terminology incorrect.

Under the advanced settings for a server, I unchecked the option regarding sub-folders and messages.

I then created a temporary folder for the already archived messages and moved the messages to it.

I changed the Archives setting to point to a local folder temporarily and deleted the old Archives directory.

I then reset the Archives setting to point to the default settings and used the Archive feature on the messages in the temporary folder.

Thunderbird successfully created the Archives directory and the appropriate sub-directories.

Comment 5

8 years ago
I thought I had solved my problem by telling Thunderbird that the server didn't handle folders that contain sub-folders and messages, but this simply made things worse. I started getting messages about the Archives folder not being selectable. This was causing a great deal of trouble with my Inbox. To get past this I ended up changing the archive granularity to put all messages into one folder rather than having them in sub-directories by year.

Thunderbird should correctly handle the case where the IMAP server is unable to support folders with messages and sub-folders, such as the Dovecot IMAP server in mbox mode.

I should mention that I also tried to use Thunderbird 3.1 Beta 2, which experienced the same issues as Thunderbird 3.0, but seemed to handle it slightly better.
Blocks: 473212
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

8 years ago
I've same problem. Archive key 'a' does not archive messages. It usually happens when on left pane, focus is not on Inbox. Suppose you've configured multiple account under Inbox. if email arrives under one account and focus is on Inbox, archiving does not work.

It is very annoying. When I click the proper individual account then archiving works.

Comment 7

8 years ago
In the above comment, 

'focus is not on Inbox' => here Inbox means inbox of a particular account, not the parent of all accounts. 

I hope that is not confusing.
(Reporter)

Comment 8

8 years ago
After upgrading to the newest version of thunderbird I have noticed an error notification when the button does not work and it says that thunderbird cannot create a folder because it already exists...

Updated

8 years ago
Summary: Archive button not always working when clicked → Archive button not always working when clicked - returns "thunderbird cannot create a folder because it already exists"
Whiteboard: dupeme

Comment 9

7 years ago
With Exim and mbox folders, the same behaviour described in this bug is experienced.

Comment 10

7 years ago
It appears that if the auto-detection method described in Bug 284933 was used, then Thunderbird could automatically archive messages in the way supported by the IMAP server.

To quote the bug:

"Just see if server returns \NoInferiors for the Trash mailbox in LIST command reply."

Updated

7 years ago
Duplicate of this bug: 661959

Comment 12

6 years ago
Created attachment 636785 [details]
mailing that I can't archive

When I press 'Archive' on this message, the mailing is not archived, but instead I get an error message: "The current operation on 'Test' did not succeed. The mail server for account somebody@somewhere.com responded: Mailbox isn't selectable: Archives/2012."
The mail account is on an dovecot IMAP server that cannot handle folders with subfolders and messages.

Upon my tests, I noted that whenever I change the address in "Delivered-To:", the message can be archived. The email address in the mailing is one of my email addresses, so maybe it is somehow connected to my account.

Comment 13

6 years ago
(In reply to Olaf Lenz from comment #12)

Some additional information: I'm using TB 13.0, the archive is created monthly.

Comment 14

6 years ago
It turns out my problem is not the same as described in this bug. In fact, my problem is not so much of a bug, but more of a usability problem.
The thing is, that different mail identities may have different archiving options. For my default mail account, the settings were to create monthly archives, but for another identity, the archiving options were still "yearly archives".
In conjunction with folders that cannot contain mail and subfolders, this creates problems. When trying to archive mail for the alternative identity, TB tries to put it into the yearly archive folder Archives/2012, which already contains subfolders from the monthly archive of the default identity. This causes the bug.

Updated

6 years ago
Depends on: 799821
You need to log in before you can comment on or make changes to this bug.