Closed Bug 551438 Opened 11 years ago Closed 11 years ago

Require system libpng to be at version 1.4.1 or later

Categories

(Core :: ImageLib, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: glennrp+bmo, Assigned: glennrp+bmo)

References

Details

Attachments

(1 file)

Now that libpng-1.4.1 has been checked in to trunk (bug #544747), we should also require that if a system libpng is being used, that should also be at version 1.4.1 or later.  This will permit us to simplify nsPNGDecoder.cpp.
Tryserver tells me that the current nsPNGDecoder.cpp doesn't work with libpng-1.4.1 as the system library because of a typo: png_set_user_chunk_malloc_max() should be
png_set_chunk_malloc_max().  I'll upload a patch shortly, as soon
as the Tryserver is done.
Severity: minor → major
Tryserver is failing four of the png-writing unit tests when I run with system libpng-1.4.1 (actually the embedded one with "include mozpngconf.h" commented out of pngconf.h).
Fixes png_set_chunk_malloc_max() typo in nsPNGDecoder.cpp and requires libpng-1.4.0 in configure.in
Attachment #432167 - Flags: review?(joe)
Tryserver builds with the v00 patch are at
http://build.mozilla.org/tryserver-builds/glennrp@gmail.com-v00e-551438-12March-embedded-1.4.1

Also, tryserver builds with "#include mozpngconf.h" commented out of pngconf.h to simulate using the v00 patch with the system libpng-1.4.1 are at
http://build.mozilla.org/tryserver-builds/glennrp@gmail.com-v00f-551438-12March-system-1.4.1

Tbere are still a few sporadic unittest failures but they seem to be unrelated to whether this patch is applied or not.  I can't reproduce the failures I reported in comment #2.
Duplicate of this bug: 556117
Attachment #432167 - Flags: review?(joe) → review+
Keywords: checkin-needed
(In reply to comment #3)
> Created an attachment (id=432167) [details]
> v00: require system libpng to be version 1.4.1 or later

Pushed as: http://hg.mozilla.org/mozilla-central/rev/f5d06bf2b77f
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Blocks: 608483
You need to log in before you can comment on or make changes to this bug.