Intermittent browser_forgetthissite_single.js | Test timed out

RESOLVED FIXED in Future

Status

()

P3
normal
RESOLVED FIXED
9 years ago
2 months ago

People

(Reporter: dholbert, Assigned: Ehsan)

Tracking

({intermittent-failure})

Trunk
Future
x86
Linux
intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268248281.1268250345.31830.gz
Linux mozilla-central debug test mochitest-other on 2010/03/10 11:11:21
s: moz2-linux-slave28

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Timed out

FWIW, timeout happened after a test-failure in browser_bookmarksProperties.js was reported *during* the browser_forgetthissite_single.js test. (see context below)  (I filed bug 551538 on the browser_bookmarksProperties.js failure.)

{
Running chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js...
Chrome file doesn't exist: /builds/slave/mozilla-central-linux-debug-unittest-mochitest-other/build/mochitest/browser/browser/components/places/tests/browser/head.js
TEST-PASS | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | checking PlacesUtils, running in chrome context?
TEST-PASS | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | http://www.mozilla.org/test1 successfully marked visited
TEST-PASS | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | http://www.mozilla.org/test2 successfully marked visited
pldhash: for the table at address 0xbaeccb8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0xbaecc50 == 9
++DOMWINDOW == 38 (0xbb68a10) [serial = 508] [outer = (nil)]
++DOMWINDOW == 39 (0xa4dd760) [serial = 509] [outer = 0xbb689e0]
pldhash: for the table at address 0xb8aad08, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0xb8aaca0 == 10
++DOMWINDOW == 40 (0xb6c6fd0) [serial = 510] [outer = (nil)]
++DOMWINDOW == 41 (0xb7258b8) [serial = 511] [outer = 0xb6c6fa0]
TEST-PASS | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_bookmarksProperties.js | EditItemOverlay is initialized
TEST-PASS | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The selected range is as big as expected
++DOMWINDOW == 42 (0xb0412c8) [serial = 512] [outer = 0xb6c6fa0]
TEST-PASS | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_bookmarksProperties.js | We are editing new folder name in folder tree
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_bookmarksProperties.js | We have finished editing folder name in folder tree
TEST-PASS | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_bookmarksProperties.js | Dialog window should not be closed by pressing ESC in folder name textbox
WARNING: Should not try to set the focus on a disabled window: file /builds/moz2_slave/mozilla-central-linux-debug/build/dom/base/nsGlobalWindow.cpp, line 4331
[-----SNIP-------]
TEST-INFO | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Warning: "Unknown property 'zoom'.  Declaration dropped." {file: "http://www.mozilla.org/style/screen.css" line: 90}]
TEST-INFO | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Warning: "Error in parsing value for 'letter-spacing'.  Declaration dropped." {file: "http://www.mozilla.org/style/screen.css" line: 347}]
TEST-INFO | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Warning: "Unknown property 'border-radius'.  Declaration dropped." {file: "http://www.mozilla.org/style/screen.css" line: 412}]
TEST-INFO | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Warning: "Unknown property 'border-radius'.  Declaration dropped." {file: "http://www.mozilla.org/style/enhanced.css" line: 44}]
TEST-INFO | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Warning: "Unknown property 'border-radius'.  Declaration dropped." {file: "http://www.mozilla.org/style/enhanced.css" line: 49}]
TEST-INFO | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Warning: "Unknown property 'border-top-right-radius'.  Declaration dropped." {file: "http://www.mozilla.org/style/enhanced.css" line: 53}]
TEST-INFO | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Warning: "Unknown property 'border-bottom-right-radius'.  Declaration dropped." {file: "http://www.mozilla.org/style/enhanced.css" line: 57}]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Timed out
TEST-INFO | checking window state
TEST-INFO | (browser-test.js) | Waiting for window activation...
Running chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_history_sidebar_search.js...
}
so this does not look like valid, if a previous test fails that way (that means it just was in need of a longer timeout) next failures are not interesting at all.
we should increase timeout for bookmarksProperties test.
increased timeout of bookmarksProperties test
http://hg.mozilla.org/mozilla-central/rev/287a073c6b3c
i'm resolving since i think this failure was just due to previous tests failing.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
Assignee: nobody → mak77
Flags: in-testsuite+
Comment hidden (Treeherder Robot)
It kind of looks like this is back. Reopening...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Duplicate of this bug: 570377
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to comment #6)
> It kind of looks like this is back. Reopening...

Linux-only, starting on 20100916? Sounds remarkably like rather than being "back" it's something completely different, another result of bug 522956, like bug 597029.
Assignee: mak77 → enndeakin
Blocks: 522956
Status: REOPENED → NEW
Depends on: 597029
Target Milestone: mozilla1.9.3a5 → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

8 years ago
Assignee: enndeakin → nobody
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 85

8 years ago
Created attachment 482379 [details] [diff] [review]
Patch (v1)

Parallel fix to attachment 482378 [details] [diff] [review].
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #482379 - Flags: review?(dolske)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Attachment #482379 - Flags: review?(dolske) → review+
Comment hidden (Treeherder Robot)
(Assignee)

Comment 97

8 years ago
http://hg.mozilla.org/mozilla-central/rev/90910202eb61

I'll mark this as FIXED.  Please feel free to reopen if it happens in the
future.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Comment hidden (Treeherder Robot)
(Assignee)

Comment 99

8 years ago
(In reply to comment #98)
> ehsan%mozilla.com
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1286941405.1286942324.18612.gz
> Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2010/10/12 20:43:25

This is happening again, in another form:

TEST-START | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | checking PlacesUtils, running in chrome context?
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | http://www.mozilla.org/test1 successfully marked visited
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | http://www.mozilla.org/test2 successfully marked visited
TEST-INFO | before wait for focus -- loaded: uninitialized active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object ChromeWindow]) about:blank desired window: ([object ChromeWindow]) about:blank child window: ([object ChromeWindow]) about:blank docshell visible: true
TEST-INFO | must wait for load
TEST-INFO | must wait for focus
TEST-INFO | waitForEvent called <type:load, target[object XULDocument]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object ChromeWindow]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:false> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object ChromeWindow]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | waitForEvent called <type:focus, target[object XULDocument]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The selected range is as big as expected
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The Forget this site menu item should not be hidden with 1 items selected
TEST-INFO | before wait for focus -- loaded: uninitialized active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) about:blank child window: ([object ChromeWindow]) about:blank docshell visible: true
TEST-INFO | must wait for load
TEST-INFO | must wait for focus
TEST-INFO | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Error: "An error occurred updating the cmd_selectAll command: [Exception... "'[JavaScript Error: "this._view.result is null" {file: "chrome://browser/content/places/controller.js" line: 179}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data: yes]" {file: "chrome://global/content/globalOverlay.js" line: 86}]
TEST-INFO | waitForEvent called <type:load, target[object XULDocument]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: <no window focused> desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:false> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: <no window focused> desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | waitForEvent called <type:focus, target[object XULDocument]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The selected range is as big as expected
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The Forget this site menu item should be hidden with 2 items selected
TEST-INFO | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Test took 0.632s to complete

TEST-INFO | checking window state
TEST-INFO | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object ChromeWindow]) about:blank docshell visible: true
TEST-INFO | must wait for focus
TEST-INFO | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Console message: [JavaScript Error: "An error occurred updating the cmd_selectAll command: [Exception... "'[JavaScript Error: "this._view.result is null" {file: "chrome://browser/content/places/controller.js" line: 179}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data: yes]" {file: "chrome://global/content/globalOverlay.js" line: 86}]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | application timed out after 330 seconds with no output


Here's a successful log for comparison:

TEST-START | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | checking PlacesUtils, running in chrome context?
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | http://www.mozilla.org/test1 successfully marked visited
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | http://www.mozilla.org/test2 successfully marked visited
TEST-INFO | before wait for focus -- loaded: uninitialized active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) about:blank child window: ([object ChromeWindow]) about:blank docshell visible: true
TEST-INFO | must wait for load
TEST-INFO | must wait for focus
TEST-INFO | waitForEvent called <type:load, target[object XULDocument]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:false> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | waitForEvent called <type:focus, target[object XULDocument]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The selected range is as big as expected
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The Forget this site menu item should not be hidden with 1 items selected
TEST-INFO | before wait for focus -- loaded: uninitialized active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) about:blank child window: ([object ChromeWindow]) about:blank docshell visible: true
TEST-INFO | must wait for load
TEST-INFO | must wait for focus
TEST-INFO | waitForEvent called <type:load, target[object XULDocument]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:false> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | waitForEvent called <type:focus, target[object XULDocument]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/places/places.xul child window: ([object ChromeWindow]) chrome://browser/content/places/places.xul docshell visible: true
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The selected range is as big as expected
TEST-PASS | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | The Forget this site menu item should be hidden with 2 items selected
TEST-INFO | chrome://mochitests/content/browser/browser/components/places/tests/browser/browser_forgetthissite_single.js | Test took 0.528s to complete

TEST-INFO | checking window state
TEST-INFO | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/places/places.xul focused window: ([object ChromeWindow]) chrome://browser/content/places/places.xul desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
TEST-INFO | must wait for focus
TEST-INFO | waitForEvent called <type:focus, target[object XPCNativeWrapper [object HTMLDocument]]> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
TEST-INFO | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We did actually see a few of those along the way, just didn't notice that they weren't the same thing.
Summary: sporadic timeout in browser_forgetthissite_single.js → Intermittent browser_forgetthissite_single.js | application timed out after 330 seconds with no output
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 104

8 years ago
Created attachment 482877 [details] [diff] [review]
Followup

This is a followup to fix the JS error and wait for the organizer window to be closed the main browser window to be focused back before attempting to proceed with the test.
Attachment #482877 - Flags: review?(dolske)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Depends on: 543278
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
No real surprise that we sort of screwed up when we morphed from the initial timeout to the 330 second timeout, since now it's about both the 330 second timeout and the return of the original timeout to Mac 10.5 with the new 1600x1200 resolution, but one of those is a [test which aborts the suite].
Whiteboard: [orange] → [orange][test which aborts the suite]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 482877 [details] [diff] [review]
Followup

>+++ b/browser/components/places/content/controller.js
>     case "cmd_selectAll":
>-      if (this._view.selType != "single") {
>+      if (this._view && this._view.selType != "single") {

This change seems unrelated, remove. _view should have a value from the constructor (unless the window in closing, you said?), and there are other places in this function it's used without null-checking. If it's a problem, seems like it's deeper than just a 1-line fix, so file a followup if you want to investigate it?

rs=me on the rest.
Attachment #482877 - Flags: review?(dolske) → review+
Comment hidden (Treeherder Robot)
(Assignee)

Comment 223

8 years ago
http://hg.mozilla.org/mozilla-central/rev/3ba3801c9a14
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
fwiw, these tests should use waitForClearHistory before finish() to avoid polluting other tests (you can copy past it from another test).
Also, are you sure onLoad always comes after focus? To me looks like the test tries to select a node too early, it should wait for load and executeSoon on it. browser_library_infoBox.js does not seem to fail intermittently, it is waiting for DOMWindowOpened, load, executeSoon (onLoad the tree populates) and focusing gLibrary.PlacesOrganizer._places.focus() (this could make the trick?). it is also waiting for focus but most likely it has it already, but it shouldn't hurt.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Summary: Intermittent browser_forgetthissite_single.js | application timed out after 330 seconds with no output → Intermittent browser_forgetthissite_single.js | application timed out after 330 seconds with no output or Test timed out
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 263

8 years ago
(In reply to comment #228)
> fwiw, these tests should use waitForClearHistory before finish() to avoid
> polluting other tests (you can copy past it from another test).

Done.

> Also, are you sure onLoad always comes after focus?

waitForFocus guarantees that the window is loaded and focused.

> To me looks like the test
> tries to select a node too early, it should wait for load and executeSoon on
> it. browser_library_infoBox.js does not seem to fail intermittently, it is
> waiting for DOMWindowOpened, load, executeSoon (onLoad the tree populates) and
> focusing gLibrary.PlacesOrganizer._places.focus() (this could make the trick?).
> it is also waiting for focus but most likely it has it already, but it
> shouldn't hurt.

waitForFocus first checks to see if the window is loaded or not.  If it's not, it waits for the load event: <http://mxr.mozilla.org/mozilla-central/source/testing/mochitest/tests/SimpleTest/SimpleTest.js#391>.

Let's try the executeSoon idea, although I'm not sure why it would help.

I tried PlacesOrganizer._places.focus(), and it causes the test to fail for some reason!

I relanded the patch with these changes (as an aside, I had landed an outdated version of the patch in comment 223 -- no wonder it caused test failures).

http://hg.mozilla.org/mozilla-central/rev/89963dd9890f
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
That's from after you landed :(
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
these are haings in waiting for popupShown of the context menu. either the synthesized click is not enough, or the event is prevented by a previous failure... we could try using capture on popupShown to run earlier and avoid the second issue. Also try to synth the click in the middle using height and width.
looks improved overall.
also, why not directly synhtesizing a popupshowing event to the context popup element and checking your stuff instead of really opening the popup?
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 274

8 years ago
(In reply to comment #267)
> these are haings in waiting for popupShown of the context menu. either the
> synthesized click is not enough, or the event is prevented by a previous
> failure... we could try using capture on popupShown to run earlier and avoid
> the second issue. Also try to synth the click in the middle using height and
> width.
> looks improved overall.

I switched to handling the event in the capturing phase.  Also, I was apparently on crack or something, because I was trying to add an object to 4!  ;-)  I switched to clicking in the middle of the area as well.

(In reply to comment #268)
> also, why not directly synhtesizing a popupshowing event to the context popup
> element and checking your stuff instead of really opening the popup?

I tried it, but it didn't work.

(In reply to comment #269)
> What about using
> http://mxr.mozilla.org/mozilla-central/source/testing/mochitest/tests/SimpleTest/EventUtils.js#234
> instead of number munging?

That function is not a general function, and cannot be used here.

I landed these fixes as: http://hg.mozilla.org/mozilla-central/rev/3515ce21be42.  Let's hope this solves the issue, as I'm running out of new ideas very quickly.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to comment #274)
> I switched to handling the event in the capturing phase.

but not the removeEventListener calls! please switch them as well.
btw, this still fails to open the context menu :(
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 283

8 years ago
(In reply to comment #279)
> btw, this still fails to open the context menu :(

What do you mean?
(Assignee)

Comment 284

8 years ago
(In reply to comment #278)
> (In reply to comment #274)
> > I switched to handling the event in the capturing phase.
> 
> but not the removeEventListener calls! please switch them as well.

Oops, yes, will switch them as well.
(In reply to comment #283)
> (In reply to comment #279)
> > btw, this still fails to open the context menu :(
> 
> What do you mean?

that after the fix there was another failure timing out while waiting for popupshown
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 289

8 years ago
(In reply to comment #285)
> (In reply to comment #283)
> > (In reply to comment #279)
> > > btw, this still fails to open the context menu :(
> > 
> > What do you mean?
> 
> that after the fix there was another failure timing out while waiting for
> popupshown

Yes.  Question is, do you have any other ideas for us to try?

One thing that's puzzling is that I haven't seen the PB equivalent test fail recently at all.
Comment hidden (Treeherder Robot)
> Yes.  Question is, do you have any other ideas for us to try?
> 
> One thing that's puzzling is that I haven't seen the PB equivalent test fail
> recently at all.

no, my only idea was to synth popupshowing directly... Maybe interaction with the previous test?
(Assignee)

Comment 292

8 years ago
(In reply to comment #284)
> (In reply to comment #278)
> > (In reply to comment #274)
> > > I switched to handling the event in the capturing phase.
> > 
> > but not the removeEventListener calls! please switch them as well.
> 
> Oops, yes, will switch them as well.

Done: http://hg.mozilla.org/mozilla-central/rev/a2f52283e534
(Assignee)

Updated

8 years ago
Whiteboard: [orange][test which aborts the suite] → [orange]
(Assignee)

Comment 293

8 years ago
(In reply to comment #291)
> > Yes.  Question is, do you have any other ideas for us to try?
> > 
> > One thing that's puzzling is that I haven't seen the PB equivalent test fail
> > recently at all.
> 
> no, my only idea was to synth popupshowing directly... Maybe interaction with
> the previous test?

Hmm, is it possible that a previous test is leaving the organizer window open?
Comment hidden (Treeherder Robot)
(Assignee)

Updated

8 years ago
Summary: Intermittent browser_forgetthissite_single.js | application timed out after 330 seconds with no output or Test timed out → Intermittent browser_forgetthissite_single.js | Test timed out
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to comment #293)
> Hmm, is it possible that a previous test is leaving the organizer window open?

not open, but maybe closing. btw, I can't think of a relation with the context menu popup, the test should fail before, right?
(Assignee)

Comment 298

8 years ago
(In reply to comment #297)
> (In reply to comment #293)
> > Hmm, is it possible that a previous test is leaving the organizer window open?
> 
> not open, but maybe closing. btw, I can't think of a relation with the context
> menu popup, the test should fail before, right?

No, why?
well, if the library is closing I can't see how we could select stuff and check size of the selection... If library is open, we would timeout at domwindowopen
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 302

8 years ago
(In reply to comment #299)
> well, if the library is closing I can't see how we could select stuff and check
> size of the selection...

Well, maybe we can't, and something throws along the line for example, so we never actually try to open the context menu?

> If library is open, we would timeout at domwindowopen

Yes, so this is probably not the case.
(Assignee)

Comment 303

8 years ago
Well, I don't think that another library window is open anyways, since we have the following in the logs right before the failure:

Version: 2.0 NVIDIA-1.5.48
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce 9400 OpenGL Engine
FBO Texture Target: TEXTURE_2D

Which suggests that the window is actually opened fresh...
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)