­ entity not working as it should, it's ignored instead

VERIFIED DUPLICATE of bug 9101

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 9101
17 years ago
16 years ago

People

(Reporter: Thomas Nilsson, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (Win98; U)
BuildID:    2000080712

­ is just ignored instead of inserting a hypen and breaking the word, 
example: verylong­word would render: verylongword even if it has reached the 
point where normal spaces would be broken down to linefeeds. it should infact 
be:
(text) verylong-
word (continuation of text)


Reproducible: Always
Steps to Reproduce:
1. Write a line longer than the width of the browser window.
2. put ­ in the middle
3. load the page, and it's scrollable instead of two lines.

Actual Results:  it wrote the whole line on one row and made the window 
scrollable					

Expected Results:  it should have broken the line in two parts and added a 
hyphen to the first line.

Comment 1

17 years ago
Although perhaps not ideal, it is acceptable behaviour for a browser. This issue
has been discussed under bug #31304

Comment 2

17 years ago
0h, parser-boy...
Assignee: clayton → rickg
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
After testing, I've concluded that the parsing engine is in fact passing 173 
back (as prescribed in the ncr table for HTML) as the value for this entity. The 
problem seems to be a rendering issue. Over to kevin for triage -- could this be 
a font problem?
Assignee: rickg → kmcclusk

Comment 4

17 years ago
Duplicate of bug 9101 (VERIFIED/LATER)

*** This bug has been marked as a duplicate of 9101 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.