Closed Bug 552047 Opened 10 years ago Closed 9 years ago

D&D to tab bar has misleading drop indicator when dropping on tab

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b7

People

(Reporter: fryn, Unassigned)

References

Details

(Whiteboard: [fixed by bug 320638])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1030 Safari/532.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100311 Minefield/3.7a3pre

When dragging an item to the tab bat, the drop indicator is displayed between tabs even when the item would be loaded in an existing tab.

Reproducible: Always

Steps to Reproduce:
1. Drag a link to the tab bar on top of the middle of a tab, and hold mouse down.
Actual Results:  
The tab drop indicator will be displayed on the left side of the tab if the cursor is on the left half of the tab or on the right side of the tab if the cursor is on the right half of the tab.

Expected Results:  
When the cursor in the middle third of the tab (horizontally), the tab drop indicator should be displayed on top of the tab itself.

See Google Chrome for a consistent UI implementation of this. Make sure that the tab drop indicator actually matches where the item will be loaded. This should be part of the Firefox 4 UI refresh.
The User-Agent above is Chrome, because I was testing how the UI works in Chrome when filing this :P
Lets ask our ux team.
Keywords: uiwanted
yep, this is a flaw.  The item should turn into a new tab as soon as it enters the tab strip, and from there behave similar to a tab reordering operation until upclick.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
(In reply to comment #3)
> yep, this is a flaw.  The item should turn into a new tab as soon as it enters
> the tab strip, and from there behave similar to a tab reordering operation
> until upclick.

If that's the case, this should depend on bug 455694.
Depends on: 455694
Keywords: uiwanted
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
(In reply to comment #3)
> yep, this is a flaw.  The item should turn into a new tab as soon as it enters
> the tab strip, and from there behave similar to a tab reordering operation
> until upclick.

this sounds like bug 320638 or bug 320639
Fixed by bug 320638.
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 455694
Resolution: --- → WORKSFORME
Depends on: 320638
Resolution: WORKSFORME → FIXED
Whiteboard: [fixed by bug 320638]
Target Milestone: --- → Firefox 4.0b7
You need to log in before you can comment on or make changes to this bug.