File association icon is set to generic

RESOLVED FIXED

Status

defect
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: base12, Assigned: mcsmurf)

Tracking

({regression})

Bug Flags:
blocking-seamonkey2.0.4 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9pre) Gecko/20100312 SeaMonkey/2.0.4pre compatible Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9pre) Gecko/20100312 SeaMonkey/2.0.4pre

The installer for SeaMonkey 2.x seems to set the default icon for .html, .htm and .shtml files to be the generic Windows file icon. Other SM file type, such as .eml files, get the icon that looks like a piece of paper with the top right corner folded and the SM logo on it.

Reproducible: Sometimes

Steps to Reproduce:
1. Install or update SM 2.x
2. Look for .html file and check icon
3.
Actual Results:  
The .html file may have a generic Windows icon.

Expected Results:  
The file should have a SM document icon.

I've figured out why the icon is displayed incorrectly. As far as I can tell, the installer uses the registry key 

HKEY_CLASSES_ROOT\SeaMonkeyHTML

to store the icon information, specifically in the ShellEx subkey. Whenever I delete the ShellEx subkey, and then log out and  log in again, the affected files have the correct document icon.

I did this a couple of weeks ago. I'm using the 2.0.4pre nightly builds, which I update every day or two. The correct icon stayed in place until a couple of days ago, but I never log out of my PC. The icon got reset to the generic one after the Tuesday Windows update restarted my PC. I reset the icon again. After updating the SM nightly today, I logged out of my PC and back in again. So far the icon is still the correct one. So, it appears that some SM updates will reset the icon, but others don't.

This is happening for other SM users, some of whom use release builds, not nightly builds. See http://forums.mozillazine.org/viewtopic.php?f=3&t=1641705 for additional information.
Confirming per mozillazine link.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-seamonkey2.0.4?
Keywords: regression
Version: unspecified → SeaMonkey 2.0 Branch

Comment 2

9 years ago
We won't block a release on this minor glitch, but we'd accept a patch. Frank might know how to correctly fix this problem.
Flags: blocking-seamonkey2.0.4? → blocking-seamonkey2.0.4-
Flags: wanted-seamonkey2.0?
Assignee

Comment 3

9 years ago
Andy: What keys/values can be found in that ShellEx subkey?

Related: Bug 507896
Reporter

Comment 4

9 years ago
It contained only one key, which I'm pretty sure was IconHandler. Unfortunately I didn't keep a record of what the value was. I'm guessing that since I had deleted the ShellEx subkey and then it returned, the installer must occasionally put the subkey back. I've tried updating the 2.0.4pre nightly the last couple of days, and then looked in the Windows registry, but so far it hasn't returned. All I can tell you is that about February 25 I deleted the ShellEx key and sometime between then and March 9 the key returned. I'll keep watching for it whenever I run the SM update, which is just about every day.

Updated

9 years ago
Flags: wanted-seamonkey2.0?

Comment 5

9 years ago
In the Windows registry SeaMonkey does not set during installation

...\HKEY_CLASSES_ROOT\CLSID\...\Old Icon\SeaMonkeyHTML\DefaultIco
...\HKEY_LOCAL_Machine\SOFTWARE\Classes\CLSID\...\Old Icon\SeaMonkeyHTML\DefaultIco

the key to "C:\...\SeaMonkey\chrome\icons\default\html-file.ico,0"

I can see the right SeaMonkey .html icon in windows explorer after setting the above key manually.

Maybe also the following one needs to be removed or changed, too:
...\HKEY_CLASSES_ROOT\CLSID\...\Old Icon\MozillaHTML\DefaultIco
...\HKEY_LOCAL_Machine\SOFTWARE\Classes\CLSID\...\Old Icon\MozillaHTML\DefaultIco

Comment 6

9 years ago
DefaultIco should be DefaultIcon (typo in last comment):
Reporter

Comment 7

9 years ago
(In reply to comment #3)
> Andy: What keys/values can be found in that ShellEx subkey?

This problem didn't return for a long time, but I just noticed today that the icon showing for .html files had reverted to the generic Windows one. The ShellEx subkey is back. Here's an export from the registry.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\mhtmlfile\ShellEx\IconHandler]
@="{42042206-2D85-11D3-8CFF-005004838597}"

Here are other instances where the same value appears.

[HKEY_CLASSES_ROOT\MozillaHTML\ShellEx\IconHandler]
@="{42042206-2D85-11D3-8CFF-005004838597}"

[HKEY_CLASSES_ROOT\ODCfile\ShellEx\IconHandler]
@="{42042206-2D85-11D3-8CFF-005004838597}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved]
"{42042206-2D85-11D3-8CFF-005004838597}"="Microsoft Office HTML Icon Handler"


I dug up a little information on Microsoft Office HTML Icon Handler. Apparently there's a bug in WinXP. See these for additional information.

http://support.microsoft.com/kb/935774
http://richardrudek.spaces.live.com/blog/cns!8B65F3DE0BE797AA!219.entry

So the only question is, why does the ShellEx subkey keep coming back after I delete it? Is the SeaMonkey updater doing it, or is it something in Windows?
Reporter

Comment 8

9 years ago
Oops, I meant to put this one at the top of the registry export.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\SeaMonkeyHTML\ShellEx\IconHandler]
@="{42042206-2D85-11D3-8CFF-005004838597}"

Comment 9

9 years ago
I ran into this issue after the initial upgrade from 1.1.18 to 2.0 on WinXP. Running 2.0.4, I've removed the ShellEx registry subkey as proposed by Andy.

Now I've updated to 2.0.5, where the entry didn't reappear and I still see the correct SeaMonkey icon for .html files. This was a partial update (betatest).

Comment 10

8 years ago
Mcsmurf, I presume that this is fixed in SeaMonkey 2.1?

Comment 11

8 years ago
> Mcsmurf, I presume that this is fixed in SeaMonkey 2.1?
Apparently not.
Assignee

Comment 12

8 years ago
Posted patch Patch (obsolete) — Splinter Review
This adds an icon index as under some circumstances Windows seems to have problems when no icon index is given.
Assignee: nobody → bugzilla
Attachment #561880 - Flags: review?(neil)
Comment on attachment 561880 [details] [diff] [review]
Patch

Weird... but I can confirm that on a PC with SeaMonkey and Office 2003, the latter installs something in the registry that overrides the default icon, and patching its copy of the above registry entry already started making the correct icon appear in property dialogs and new shortcuts.

I notice that Netscape 7.2 isn't affected because it always uses ,0 too.

Can we do EML files as well, just for consistency? Thanks.
Attachment #561880 - Flags: review?(neil) → review+
Assignee

Comment 14

8 years ago
SeaMonkey only, fixes icons used in Windows for HTML and .eml files.
Attachment #561880 - Attachment is obsolete: true
Attachment #562063 - Flags: review+
Attachment #562063 - Flags: approval-comm-beta?
Attachment #562063 - Flags: approval-comm-aurora?
Comment on attachment 562063 [details] [diff] [review]
Patch for checkin

Approval for SeaMonkey 2.5 only, (2.4 has left the station).
Attachment #562063 - Flags: approval-comm-beta?
Attachment #562063 - Flags: approval-comm-beta-
Attachment #562063 - Flags: approval-comm-aurora?
Attachment #562063 - Flags: approval-comm-aurora+
Assignee

Comment 16

8 years ago
http://hg.mozilla.org/comm-central/rev/fec4d614ba99
http://hg.mozilla.org/releases/comm-aurora/rev/37ad99156e2a

=> FIXED
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Assignee

Updated

8 years ago
Version: SeaMonkey 2.0 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.