[Nokia Ovi Suite:ThunderbirdConnector] triggers heap corruption under [@free | ThunderbirdExtension+0x4200] and crashes on shutdown with "Thunderbird has stopped working"

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: adrian.dinu87, Unassigned)

Tracking

({crash})

x86_64
Windows 7
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has stacktrace], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

Each time i close thunderbird i get a crash message from windows (Thunderbird has stopped working).

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird
2. Close Thunderbird
Actual Results:  
I get the "thunderbird has stopped working" message.

Expected Results:  
It should close without error.

If i click the view problem detail i get:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	thunderbird.exe
  Application Version:	1.9.1.3710
  Application Timestamp:	4b89b279
  Fault Module Name:	StackHash_34a4
  Fault Module Version:	6.1.7600.16385
  Fault Module Timestamp:	4a5bdb3b
  Exception Code:	c0000374
  Exception Offset:	000cdcbb
  OS Version:	6.1.7600.2.0.0.256.1
  Locale ID:	1033
  Additional Information 1:	34a4
  Additional Information 2:	34a4edc6d4eca0e9e53f6cdca9c59fe7
  Additional Information 3:	6a25
  Additional Information 4:	6a251651574f2f11b9d1cf98e5c5d3f9

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

Comment 1

9 years ago
adi, we'll need a stacktrace.  normally, you should get a crash report as described at http://kb.mozillazine.org/Breakpad#Viewing_crash_reports

If you're not getting a crash report, please get a stack with symbols using this procedure, which looks complicated but really isn't https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

the current list of shutdown crashes - https://bugzilla.mozilla.org/buglist.cgi?keywords=crash%20;query_format=advanced;keywords_type=allwords;short_desc=clos%20shut;field0-0-0=status_whiteboard;short_desc_type=anywordssubstr;type0-0-0=notsubstring;value0-0-0=notacrash;resolution=---;product=MailNews%20Core;product=Thunderbird
Keywords: crash, stackwanted
Summary: Crash each time i close thunderbird → Crash each time i close thunderbird, shutdown
Version: unspecified → 3.0
(Reporter)

Comment 2

9 years ago
Created attachment 432320 [details]
crash report
(Reporter)

Comment 3

9 years ago
I added the crash report as you requested, hope it helps.

Updated

9 years ago
Keywords: stackwanted
Whiteboard: [has stacktrace]
Dunno which timeless to add , but adding one because this might be of some interest :

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Program Files (x86)\Nokia\Nokia Ovi Suite\Connectors\Thunderbird Connector\ThunderbirdExtension\components\ThunderbirdExtension.dll - 

Marking new because we have the stack trace.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Attachment #432320 - Attachment mime type: application/octet-stream → text/plain

Updated

9 years ago
Summary: Crash each time i close thunderbird, shutdown → [Nokia Ovi Suite:ThunderbirdConnector] triggers heap corruption under [@free | ThunderbirdExtension+0x4200]
adi@turbocar.ro , could you try to contact Nokia and tell them about your issue. I have no way to contact them directly to raise a bug myself , so it's better if it's the user who does it.

http://www.nokia.ro/suport/contact is the place where you'll find the contact information (if you are indeed based in romania). The best way to get to them would be to call them. Feel free to point to this bug in order to give them more information.

Updated

9 years ago
Summary: [Nokia Ovi Suite:ThunderbirdConnector] triggers heap corruption under [@free | ThunderbirdExtension+0x4200] → [Nokia Ovi Suite:ThunderbirdConnector] triggers heap corruption under [@free | ThunderbirdExtension+0x4200] and crashes on shutdown
(Reporter)

Comment 6

9 years ago
Doesn't it make more sense to report the bug directly to Ovi support team, they have a site on www.ovi.com, I think the team on Nokia website only handles phone related problems and not the computer software support. I posted a bug report on http://support.ovi.com/index.php?id=contact&lang=en_GB&countrycode=ROMANIA and I'm waiting an answer.
(Reporter)

Comment 7

9 years ago
Reply from Nokia:

Dear Mr. Dinu,

 Thank you for the detailed info. We will send this "bug issue" to our RND (Research & Development) team in Finland.
 Hope that it will help them to fix the crash. Please do not hesitate to contact us with any problems regarding NOKIA phones and accessories.    

 Have a nice day!
 Best Regards
 Bogdan Tanase
 Nokia Care Romania

Comment 8

8 years ago
Adrian, 
What version of OVI suite where you running?
What's your current status?
And can you check with nokia on the status of your bug issue?

Many postings in forums about nokia not syncing with Thunderbird - not much about crashes though. So I don't know that this reference will help http://betalabs.nokia.com/apps/nokia-ovi-suite-2-1/bugreport/7890/graduated-ovi-suite-no-longer-synchronizes-with-thunderbird

I didn't find ThunderbirdExtension.dll@0x4200 on crash stats.

other crash sigs from the past month:
ThunderbirdExtension.dll@0x32a7 32
ThunderbirdExtension.dll@0x64f0 22 bp-06ae5cc4-3ba1-4c23-a350-bc6f12100620 (lp) Nokia OVI suite version 2.2.0.240, CCB7D94B-CA92-4E3F-B79D-ADE0F07ADC74      7.3.3.33
ThunderbirdExtension.dll@0x625e 12
ThunderbirdExtension.dll@0x5f9d 8
ThunderbirdExtension.dll@0x61c9 3
ThunderbirdExtension.dll@0x14e8 2
ThunderbirdExtension.dll@0x57a2 2
memcpy | memcpy_s | ThunderbirdExtension.dll@0x6a26 2
ThunderbirdExtension.dll@0x1513 1
(Reporter)

Comment 9

8 years ago
The problem was caused by NokiaMServer.exe, an application that runs in the background and on Windows start-up. At the time i was having the crash closing that was a good workaround.

Unfortunately i can't recall the exact version number i was using at that time, but now I'm using Nokia Ovi Suite 2.1.1.1, I'm quite sure i did about 2 updates since i posted this bug to the ovi application. Thunderbird is at 3.0.5 and was at 3.0.3 back then.

Running everything on default in ovi now there are no more crashes (did a fresh install to be sure), so i suppose the crash was fixed in one of the updates.

Comment 10

8 years ago
great, thanks for the update
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

8 years ago
Crash Signature: [@free | ThunderbirdExtension+0x4200]

Updated

6 years ago
Summary: [Nokia Ovi Suite:ThunderbirdConnector] triggers heap corruption under [@free | ThunderbirdExtension+0x4200] and crashes on shutdown → [Nokia Ovi Suite:ThunderbirdConnector] triggers heap corruption under [@free | ThunderbirdExtension+0x4200] and crashes on shutdown with "Thunderbird has stopped working"
You need to log in before you can comment on or make changes to this bug.