All users were logged out of Bugzilla on October 13th, 2018

dragging from Collected Addresses into List shows spurious duplicate

RESOLVED DUPLICATE of bug 85687

Status

--
minor
RESOLVED DUPLICATE of bug 85687
9 years ago
8 years ago

People

(Reporter: ihok, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

860.64 KB, application/x-shockwave-flash
Details
(Reporter)

Description

9 years ago
Version 3.0.3

1. Open Collected Addresses
2. Drag any one and drop it into a list.

Expected: 

The contact either copies or moves into the list.

Actual:

The contact copies into the list AND a spurious duplicate of the contact appears in the Collected Addresses. Clicking away from and back to CA makes the duplicate entry disappear.
Whiteboard: dupeme

Comment 1

9 years ago
I can confirm this (my thunderbird version is now: ubuntu package 3.0.4+nobinonly-0ubuntu4), but not in any cases. 

I >can't< repeat the error 
* at all in a new thunderbird profile (starting with #thunderbird -P)
* in migrated profile[1]:
** in a new created folder (i.e. addressbook) with any contact (new or from thunderbird 2)

I >can< repeat the error in migrated profile
* in a folder which existed also in thunderbird 2 with any contact

If you change the folder or list and come back, the duplicate is gone away.

Jack, please check, if it is the same situation with your version/system. 

[1] from thunderbird ubuntu package 2.0.0.24+build1+nobinonly-0ubuntu0.9.04.1

Comment 2

9 years ago
I can confirm this. After having a customer complaining about the address book and mailing lists I tried to reproduce it - and it appear the whole thing is quite broken. Lots of wired things happen when renaming contacs or putting them in mailing list. 
- renaming is not reflected in mailing list
- rename a contact and moving it to a maling list bings up old data in the mailing list.
- if there are two contact with the same email address, moving one to the mailing list does not allow the other one to be moved there too. Even if this is technically correct, it is confusing for a normal user, who care more about names than the actual email address.

Comment 3

8 years ago
I can reproduce it with "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100929 Thunderbird/3.3a1pre". If you Delete one of the contact "entries", when you move to other book and return to the first, the contact is not there anymore, both "entries" have been deleted.

Comment 4

8 years ago
(In reply to comment #3)
> I can reproduce it with "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre)
> Gecko/20100929 Thunderbird/3.3a1pre". If you Delete one of the contact
> "entries", when you move to other book and return to the first, the contact is
> not there anymore, both "entries" have been deleted.

See attached video: deleteUserMailingList.swf

Comment 5

8 years ago
Created attachment 479876 [details]
Delete User

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 85687
You need to log in before you can comment on or make changes to this bug.