"Copy to" message filter copies oldest Inbox message as body, but correct headers

RESOLVED DUPLICATE of bug 383425

Status

--
major
RESOLVED DUPLICATE of bug 383425
9 years ago
9 years ago

People

(Reporter: kevinjamesfield, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (compatible; U; InfiNet 0.1; Haiku) AppleWebKit/527+ (KHTML, like Gecko) WebPositive/527+ Safari/527+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

I set up a message filter by subject, from, and to, and set it to apply to incoming mail only.  It ran and copied many messages to the folder I specified.  Every single one of them had the correct header copied (when looking at the message list, anyway) but instead of the matching message body, it had the body of the very oldest message in the inbox.  Clicking any of the messages to view it, the headers on the list did not match the headers in the preview pane, which matched the old e-mail.  So I guess only the index got the correct information, and the mailbox itself was entirely wrong.  I opened the mailbox file directly and found that to be true--copy after copy of the oldest message and its headers.  But the list still looks correct.

I tried changing it to run on check or on manual, and changed it so that it marks it as read first, and then copies.  Seemed to work fine after that on manual runs, but upon mail checking, it exhibits a different bizarre behaviour: the first time I looked, three messages had been filtered, and the date of the newest one showed up in the copy-to folder's list three times.  Clicking any of those three showed a blank message in the preview pane.  Compacting that folder got rid of the blanks.  Now whenever new mail comes in, only the newest one seems to get copied, but its body is still blank.  I have to delete the blank one and "run on selected messages" for it to work.  (The originals are all non-blank BTW.)

Reproducible: Always

Steps to Reproduce:
1. Create "copy to" filter on check.
2. Get mail.
3. Click the folder to which filtered messages are being copied.
4. Click the newest message.
Actual Results:  
3.  Not all the messages that match the filter are present, just the newest.
4.  The body of the message is blank.

Expected Results:  
3. All the messages matching the filter would be present.
4. The correct body would appear when clicking any of them.

(I'm sure this must have been reported given how basic a scenario it is.  I spent 20 minutes sifting through search results though and could not find it.  I must not be using the proper terms.  So apologies for the likely duplication.)
(Reporter)

Comment 1

9 years ago
I can't reproduce the first behaviour, but the second one is consistent right now.  Even if I clear both the mailbox and the .msf file, and restart TB, running a check mail produces blank messages, whereas setting it to manual only and then running it on the same messages that just came in produces the correct results.

Comment 2

9 years ago
Do you have message quarantining turned on in tools | options | security, anti-virus? If so, I believe this is a dup of an existing bug.
(Reporter)

Comment 3

9 years ago
I do!  And disabling that fixed it.  Thanks very much for your help, sorry again for the dup.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383425
You need to log in before you can comment on or make changes to this bug.