Server Autoconfiguration should lookup MX DNS record and use it by default

VERIFIED DUPLICATE of bug 551519

Status

Thunderbird
Account Manager
--
minor
VERIFIED DUPLICATE of bug 551519
8 years ago
8 years ago

People

(Reporter: sibul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.9.1.8) Gecko/20100227 Lightning/1.0b1 Thunderbird/3.0.3

I run my own Mailserver (mail.example.com on my own VPS) on a different machine than my website (example.com on my ISPs Webserver) and set up MX records accordingly.

Problem is, on example.com there is also a Mailserver installed, and since it's my ISP one, I can't turn it off.

So when I add a user via the Thunderbird Account Config Wizard it adds "example.com" as Mailserver, which actualy could (!) work, since there is actualy a Mailserver running, but it does not have account data, so fails to accept username and password.

When Thunderbird would DNS lookup example.com and use the MX record as Mailserver the problem would be solved.

The workaround is adding the right server by Userinput, but it failed many times with my users. ;-)

Thanks for your time and great piece of software.

Sibul

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551519

Comment 2

8 years ago
Verified that "Use DNS MX" is a dup.

I don't know what we'll use for guessing, though. You might still run into this problem after bug 551519.

Note that mail.example.com should be searched before / preferred over example.com by Thunderbird. You'd run into the problem only if mail.example.com was not resolvable from where you are, or if the host is actually called fred.example.com instead of mail.example.com.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.