Intermittent failure in test_suspend.html | Got message before resumed! - got false, expected true

RESOLVED FIXED in mozilla1.9.3a4

Status

()

defect
RESOLVED FIXED
9 years ago
2 months ago

People

(Reporter: philor, Assigned: bent.mozilla)

Tracking

({intermittent-failure})

Trunk
mozilla1.9.3a4
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

9 years ago
Sequel to bug 552054 (there were some of these, mixed in with other stuff there).

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268852805.1268855816.9305.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/17 12:06:45
s: moz2-darwin9-slave02

597 INFO TEST-PASS | /tests/dom/src/threads/test/test_suspend.html | Data is inconsistent
598 INFO TEST-PASS | /tests/dom/src/threads/test/test_suspend.html | Data is inconsistent
599 INFO TEST-PASS | /tests/dom/src/threads/test/test_suspend.html | Wrong url!
600 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed! - got false, expected true
601 INFO TEST-PASS | /tests/dom/src/threads/test/test_suspend.html | Missed a message, suspend failed!
603 INFO Running /tests/dom/src/threads/test/test_terminate.html...
++DOMWINDOW == 23 (0x7c24090) [serial = 708] [outer = 0x7d81b50]
604 INFO TEST-PASS | /tests/dom/src/threads/test/test_terminate.html | Bad message!
Also saw this on the places branch when I test landed bug 502937 there.

http://tinderbox.mozilla.org/showlog.cgi?log=Places/1268784582.1268787086.4627.gz
OS X 10.5.2 places debug test mochitests-2/5 on 2010/03/16 17:09:42
s: moz2-darwin9-slave17
600 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed! - got false, expected true
Reporter

Comment 2

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268876436.1268879088.13053.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/17 18:40:36
s: moz2-linux-slave15
Reporter

Comment 3

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268880404.1268882775.22980.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/17 19:46:44
s: moz2-darwin9-slave06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268896701.1268899059.26033.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/18 00:18:21
s: moz2-darwin9-slave10
Reporter

Comment 6

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268911221.1268913456.11755.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/18 04:20:21
s: moz2-darwin9-slave02
Reporter

Comment 7

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268953641.1268955956.19001.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/18 16:07:21
s: moz2-linux-slave16
Reporter

Comment 8

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269046802.1269049000.20387.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/19 18:00:02
s: moz2-darwin9-slave12
Reporter

Comment 10

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269137007.1269139799.10287.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/20 19:03:27
s: moz2-linux-slave06
Reporter

Comment 11

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269144305.1269146953.23660.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/20 21:05:05
s: moz2-linux-slave06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269200738.1269203164.2466.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/21 12:45:38
s: moz2-linux-slave14
Reporter

Comment 13

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269215074.1269217477.5497.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/21 16:44:34
s: moz2-linux-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269242361.1269244669.23182.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/22 00:19:21
s: moz2-linux-slave14

The last three failures have all been on this same box (#14) and all within 12 hours.  Is that significant?
I ran the worker tests under recording 2200 times this weekend and couldn't make it fail once :(

Maybe this is somehow a pthreads issue because Windows seems extremely happy.

Comment 16

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269269955.1269272446.11928.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/22 07:59:15
Reporter

Comment 17

9 years ago
Buildbot now prefers to assign the next run of a particular test suite to the last slave that ran that suite if it's available, so a string of failures on the same slave isn't _necessarily_ significant.

Comment 18

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269289793.1269293176.11432.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/22 13:29:53

Comment 19

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269291889.1269294667.15149.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/22 14:04:49
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269301769.1269304175.10536.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/22 16:49:29
Reporter

Comment 21

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269310211.1269312784.1260.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/22 19:10:11
s: moz2-linux-slave01
Reporter

Comment 22

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269348435.1269350665.14758.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/23 05:47:15
s: moz2-darwin9-slave11
Reporter

Comment 23

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269358369.1269360992.16657.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/23 08:32:49
s: moz2-linux-slave01
Reporter

Comment 24

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269391590.1269394249.15920.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/23 17:46:30
s: moz2-darwin9-slave43
Reporter

Comment 25

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269390836.1269394050.15108.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/23 17:33:56
s: moz2-linux-slave01
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269417007.1269419517.11481.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/24 00:50:07
Posted patch PatchSplinter Review
Aha. Silly test problem. Finally figured out how to reproduce.
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #434684 - Flags: review?(jst)
Component: DOM: Mozilla Extensions → DOM
Attachment #434684 - Flags: review?(jst) → review+
http://hg.mozilla.org/mozilla-central/rev/e487174a0d5a
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
blocking2.0: ? → ---
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.3a4
Whiteboard: [orange]
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.