Intermittent failure in test_suspend.html (which also shows as being in test_terminate.html or any later test): Missed a message, suspend failed! - got 50, expected 51

RESOLVED FIXED in mozilla1.9.3a4

Status

()

defect
RESOLVED FIXED
10 years ago
4 months ago

People

(Reporter: Ehsan, Assigned: bent.mozilla)

Tracking

({intermittent-failure})

Trunk
mozilla1.9.3a4
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268426985.1268429349.24889.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/12 12:49:45

610 INFO Running /tests/dom/src/threads/test/test_terminate.html...
611 INFO TEST-PASS | /tests/dom/src/threads/test/test_terminate.html | Wrong url!
612 INFO TEST-PASS | /tests/dom/src/threads/test/test_terminate.html | Got message before resumed!
613 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51

This happened on the following revision, which is a test-only change:
http://hg.mozilla.org/mozilla-central/rev/ba56722f2e69
Duplicate of this bug: 552057
Component: DOM: Other → DOM: Mozilla Extensions
Failed earlier today on mac, too:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268392435.1268395280.10232.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/12 03:13:55
s: moz2-darwin9-slave15
OS: Windows Server 2003 → All
that failure from comment 2 had all of these failures:
600 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
605 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Got message before resumed!
606 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51
610 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Got message before resumed!
611 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Missed a message, suspend failed! - got 50, expected 52

Not filing separate bugs for them at this point, since they look like they might all be the same thing.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268433304.1268435926.8195.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/12 14:35:04
s: moz2-darwin9-slave14
600 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
605 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Got message before resumed!
606 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268436519.1268439494.17524.gz
Linux Mozilla-central debug test mochitest 2/5 on 2010/03/12 14:32:04
s: moz2-linux-slave
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268438735.1268441260.21719.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/12 16:05:35
s: moz2-darwin9-slave12
(same set of failures as in comment 3)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268441123.1268443746.26837.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/12 16:45:23
s: moz2-linux-slave15

613 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 52
618 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Missed a message, suspend failed! - got 50, expected 51
623 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadTimeouts.html | Missed a message, suspend failed! - got 50, expected 53
628 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_throwingOnerror.html | Missed a message, suspend failed! - got 50, expected 54
633 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_xhr.html | Missed a message, suspend failed! - got 50, expected 55
638 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_xhrAbort.html | Missed a message, suspend failed! - got 50, expected 56
643 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | Missed a message, suspend failed! - got 50, expected 57

Not really "in test_terminate.html" since that's a message from test_suspend.html which bug 547399 landed yesterday, continuing to be thrown into whoever happens to be running since whether or not that's the root of the problem, terminateWorker() apparently doesn't.
Blocks: 547399
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268458754.1268461075.2807.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/12 21:39:14
s: moz2-darwin9-slave12
600 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
Summary: Intermittent failure in test_terminate.html: Missed a message, suspend failed! - got 50, expected 51 → Intermittent failure in test_suspend.html (which also shows as being in test_terminate.html or any later test): Missed a message, suspend failed! - got 50, expected 51
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268487525.1268489982.27194.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/13 05:38:45
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268492220.1268495288.11949.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/13 06:57:00
s: moz2-linux-slave11
590 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268492210.1268494973.10990.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/13 06:56:50
s: moz2-darwin9-slave07
598 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
603 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Got message before resumed!
604 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51
608 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Got message before resumed!
609 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Missed a message, suspend failed! - got 50, expected 52
613 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadTimeouts.html | Got message before resumed!
614 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadTimeouts.html | Missed a message, suspend failed! - got 50, expected 53
618 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_throwingOnerror.html | Got message before resumed!
619 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_throwingOnerror.html | Missed a message, suspend failed! - got 50, expected 54
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268500320.1268503046.5166.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/13 09:12:00
s: moz2-linux-slave07
590 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
595 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Got message before resumed!
596 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268506094.1268508770.19704.gz
s: moz2-darwin9-slave07598 debug test mochitest 2/5 on 2010/03/13 10:35:23

ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
603 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Got message before resumed!
604 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51
608 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Got message before resumed!
609 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Missed a message, suspend failed! - got 50, expected 52
613 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadTimeouts.html | Got message before resumed!
614 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadTimeouts.html | Missed a message, suspend failed! - got 50, expected 53
618 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_throwingOnerror.html | Got message before resumed!
619 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_throwingOnerror.html | Missed a message, suspend failed! - got 50, expected 54
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268507851.1268510678.24593.gz
s: moz2-darwin9-slave13598 OS X 10.5.2 mozilla-central debug mochi 2/5 2010/03/13 10:57:53

ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
603 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Got message before resumed!
604 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51
608 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Got message before resumed!
609 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Missed a message, suspend failed! - got 50, expected 52
613 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadTimeouts.html | Got message before resumed!
614 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadTimeouts.html | Missed a message, suspend failed! - got 50, expected 53
618 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_throwingOnerror.html | Got message before resumed!
619 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_throwingOnerror.html | Missed a message, suspend failed! - got 50, expected 54
623 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_xhr.html | Got message before resumed!
624 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_xhr.html | Missed a message, suspend failed! - got 50, expected 55
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268516643.1268519126.12075.gz
WINNT 5.2 mozilla-central debug test mochitests-2/5 on 2010/03/13 13:44:03
s: win32-slave17
613 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268516471.1268519492.12860.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/13 13:41:11
s: moz2-linux-slave15
590 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
So when did this start to happen? Something has changed lately?
...I mean, are there any suspicious changes right before http://hg.mozilla.org/mozilla-central/rev/ba56722f2e69
Yeah, test_suspend.html landed (2010-03-11 12:36, so it got a good 15 hours in
before the first failure).
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268524433.1268527346.31871.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/13 15:53:53
s: moz2-darwin9-slave12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268550848.1268553115.14896.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/13 23:14:08
s: moz2-darwin9-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268570234.1268572538.2786.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/14 05:37:14
s: moz2-darwin9-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268575762.1268578667.21305.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/14 07:09:22
I'm working on recording this... I can't make it fail locally :(
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268601486.1268604250.18396.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/14 14:18:06
s: moz2-darwin9-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268603631.1268606902.25750.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/14 14:53:51
s: moz2-linux-slave08
590 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268611456.1268614093.13702.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/14 17:04:16
s: moz2-linux-slave13
590 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed!
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268616248.1268618640.23774.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/03/14 18:24:08
s: moz2-linux-slave13

613 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_terminate.html | Missed a message, suspend failed! - got 50, expected 51
618 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadErrors.html | Missed a message, suspend failed! - got 50, expected 52
623 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_threadTimeouts.html | Missed a message, suspend failed! - got 50, expected 53
628 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_throwingOnerror.html | Missed a message, suspend failed! - got 50, expected 54
633 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_xhr.html | Missed a message, suspend failed! - got 50, expected 55
638 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_xhrAbort.html | Missed a message, suspend failed! - got 50, expected 56
643 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/jquery/test_jQuery.html | Missed a message, suspend failed! - got 50, expected 57
648 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/mochikit/test_Mochikit.html | Missed a message, suspend failed! - got 50, expected 58
653 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/offline/test_badManifestMagic.html | Missed a message, suspend failed! - got 50, expected 59
658 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/offline/test_badManifestMime.html | Missed a message, suspend failed! - got 50, expected 60
663 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/offline/test_bug445544.html | Missed a message, suspend failed! - got 50, expected 61
668 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/offline/test_bug460353.html | Missed a message, suspend failed! - got 50, expected 62
Ok, I managed to record this, I'll see what I can figure out tomorrow. At this point further test logs are unnecessary.
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Posted patch Patch (obsolete) — Splinter Review
I think this will fix it. The suspend test is working just fine but the terminate call didn't prevent already-queued messages from running due to the way we determine if workers are canceled.
Attachment #432506 - Flags: review?(jst)
jst, this is a common tbox orange, quick review would be awesome ;)
Attachment #432506 - Flags: review?(jst) → review+
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268636134.1268638486.3035.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/14 23:55:34
s: moz2-darwin9-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268651724.1268654062.21978.gz
OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/15 04:15:24
s: moz2-darwin9-slave12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268679225.1268682401.13596.gz&fulltext=1
Linux mozilla-central debug test mochitests-2/5 [testfailed] Started 11:53, finished 12:47
Posted patch Patch, v2Splinter Review
The first patch broke some tests, this is more targeted. We're changing the behavior of terminate() here to block further messages so I've updated the tests and we'll need some dev-doc changes.
Attachment #432506 - Attachment is obsolete: true
Attachment #432618 - Flags: review?(jonas)
Comment on attachment 432618 [details] [diff] [review]
Patch, v2

>diff --git a/dom/src/threads/nsDOMWorker.h b/dom/src/threads/nsDOMWorker.h
>--- a/dom/src/threads/nsDOMWorker.h
>+++ b/dom/src/threads/nsDOMWorker.h
>@@ -287,16 +287,18 @@ private:
>   nsresult TerminateInternal(PRBool aFromFinalize);
> 
>   nsIWorkerLocation* GetLocation() {
>     return mLocation;
>   }
> 
>   PRBool QueueSuspendedRunnable(nsIRunnable* aRunnable);
> 
>+  PRBool IsCanceledNoLock();
>+

Please document what this does. (This seems to be a general problem in this class).
Attachment #432618 - Flags: review?(jonas) → review+
http://hg.mozilla.org/mozilla-central/rev/77039243a4c6
http://hg.mozilla.org/mozilla-central/rev/99ba38320cbe (for comments)
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.3a4
Blocks: 553038
Just happened again:

OS X 10.5.2 mozilla-central debug test mochitests-2/5 on 2010/03/17 19:46:44  
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268880404.1268882775.22980.gz#err0

600 INFO TEST-PASS | /tests/dom/src/threads/test/test_suspend.html | Wrong url!
601 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_suspend.html | Got message before resumed! - got false, expected true
602 INFO TEST-PASS | /tests/dom/src/threads/test/test_suspend.html | Missed a message, suspend failed!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Sorry, I didn't know about bug 553038.  Reclosing.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
Component: DOM: Mozilla Extensions → DOM
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.