All users were logged out of Bugzilla on October 13th, 2018

With text enlarged, clicking to move cursor is not accurate

RESOLVED INVALID

Status

RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: brettz9, Unassigned)

Tracking

0.6.2
x86
Windows Vista

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: 

When text size is enlarged past a certain point (using Bespin Drop-In 0.6.2), clicking does not work properly (may not move at all or move to wrong position). It does work accurately at different text sizes (from very small to medium large), but not particularly large ones.

Reproducible: Always

Steps to Reproduce:
1. Enlarge text size considerably with Bespin sample.
2. Try to click onto a different line.
3.
Actual Results:  
Doesn't move or may move inaccurately

Expected Results:  
Move to the correct position
As I asked in bug 535074 comment 1:
Does this bug have any relation to bug 487920 or bug 533631?

(Moving to Editor component, from General.)
Component: General → Editor
QA Contact: general → editor
Version: unspecified → 0.6.2
(Reporter)

Comment 2

9 years ago
No, in this case at least, no, because those relate to the cursor's appearance. This one is about limitations on where the cursor can go when an area is clicked (in an enlarged document).
Is this bug still present in the latest Bespin code?

Comment 4

9 years ago
I set the fontsize to 100 and increased the browsers fontsize by pressing CMD&+. The mouse selection was not correct then.

Comment 5

8 years ago
ACETRANSITION

The Skywriter project has merged with Ajax.org's Ace project (the full server part of which is their Cloud9 IDE project). Background on the change is here:

http://mozillalabs.com/skywriter/2011/01/18/mozilla-skywriter-has-been-merged-into-ace/

The bugs in the Skywriter product are not necessarily relevant for Ace and quite a bit of code has changed. For that reason, I'm closing all of these bugs. Problems that you have with Ace should be filed in the Ace issue tracker at GitHub:

https://github.com/ajaxorg/ace/issues
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.