[D2D] Rendering starts failing after browser has been open for a while

RESOLVED DUPLICATE of bug 587379

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 587379
8 years ago
8 years ago

People

(Reporter: ted, Assigned: bas)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 433327 [details]
screenshot

I've seen this happen each of the past two days. After my browser has been open long enough, the rendering stops working correctly. Lots of things fail to paint (see screenshot). Bas suggested we might be leaking VRAM or something.

I'm on Windows 7 x64, with an ATI Radeon X1300/X1550 Series with the WDDM driver (version 8.56.1.15).
(Assignee)

Comment 1

8 years ago
I wonder if this is the same as bug 508708.
(Reporter)

Comment 2

8 years ago
That's a Bespin bug. What bug did you really mean?
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> That's a Bespin bug. What bug did you really mean?

Hrm, sadly I don't remember now. We fixed a couple of memory leaks though! You should see if it's better for you now. There's still a memory leak that has a patch still under review though. Once that is fixed and it still happens, I'll need to see if I can come up with something else.
My browser lifetime is about 1-2 hours with TabCandy & D2D enabled.  At the end
of that the browser starts randomly not rendering parts of the screen and
eventually crashes.  And the workingset size of the browser is usually around
750mb when it comes apart.  This is my worst problem with Firefox right now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587379
You need to log in before you can comment on or make changes to this bug.