Closed Bug 553277 Opened 10 years ago Closed 6 years ago

thunderbird removes spaces from lines that only consist of one or more spaces.

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 645771

People

(Reporter: sassmann, Unassigned)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.8) Gecko/20100216 Fedora/3.5.8-1.fc12 Firefox/3.5.8
Build Identifier: 

thunderbird seem to remove spaces from lines that only consist of one or
more spaces. Any way of preventing thunderbird from doing so? I already
have "mailnews.send_plaintext_flowed false" and turned of line wrapping.
With these option sending patches works pretty well, only recently I
had a patch that got corrupted because of spaces being removed.

Thunderbird shouldn't remove these spaces, imho.

Reproducible: Always

Steps to Reproduce:
1. write ne e-mail with a line containing only of a space
2. save as draft
3. reopen draft and see that space is gone
Actual Results:  
spaces get removed

Expected Results:  
spaces should stay where they are
Which Thunderbird version are you using, 3.0.x? The space-handling behavior
was changed by bug 215068 from 2.0.0.x versions.
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.8) Gecko/20100301 Fedora/3.0.3-1.fc12 Thunderbird/3.0.3
The only reason for deleting spaces on a line I could find was
RFC3676 - The Text/Plain Format and DelSp Parameters
http://www.faqs.org/rfcs/rfc3676.html

4.1.  Interpreting Format=Flowed

   If the first character of a line is a quote mark (">"), the line is
   considered to be quoted (see Section 4.5).  Logically, all quote
   marks are counted and deleted, resulting in a line with a non-zero
   quote depth, and content.  (The agent is of course free to display
   the content with quote marks or excerpt bars or anything else.)
   Logically, this test for quoted lines is done before any other tests
   (that is, before checking for space-stuffed and flowed).

   If the first character of a line is a space, the line has been
   space-stuffed (see Section 4.4).  Logically, this leading space is
   deleted before examining the line further (that is, before checking
   for flowed).

4.  The Format and DelSp Parameters

   If DelSp is not specified, or if its value is not recognized, a value
   of No is assumed.  The use of DelSp without a Format value of Flowed
   is undefined.  When creating messages, DelSp SHOULD NOT be specified
   in Text content types other than Text/Plain with Format = Flowed.
   When receiving messages, DelSp SHOULD be ignored if used in a Text
   content type other than Text/Plain with Format = Flowed.

But this doesn't apply in this case as I already set
mailnews.send_plaintext_flowed false
Thunderbird 3.0.4 removes spaces *within* quoted lines when replying to a posting or using "quote message"; my last 2.x version of TB didn't.

This makes it darned near impossible to reply to postings with quoted code.

I'm thinking of writing a TBQuoteFix extension, in the spirit of the OEQuoteFix extension for Microsoft's Outlook Express (OEQuoteFix, in its time, made the extreme incompetence and mental retardedness of Microsoft engineers clear for all to see, and now it's that way with Thunderbird). It's the same kind of idiot's functionality as Microsoft is infamous for. Please find out who the heck introduced this  --  I suspect that you'll find some association with Microsoft, it's their kind of thing  --  and dump at least six hundred and sixty sic cubic metres of stinking effluence on him, preferably in his flat, not outdoors.
Also thunderbird 3.1.10 removes trailing whitespaces on any line, which it should not do. Or at least it should be configurable as it kills sending of inline patches if the context of the patch contains a trailing whitespace.

Btw, any update on this?
perhaps a dupe of Bug 645771
(In reply to Thomas D. from comment #6)
> perhaps a dupe of Bug 645771

shall wee assume so, and reopen if bug 645771 doesn't fix?
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Component: General → Message Compose Window
Depends on: 645771
Resolution: --- → DUPLICATE
Duplicate of bug: 645771
You need to log in before you can comment on or make changes to this bug.