Closed Bug 553390 Opened 10 years ago Closed 9 years ago

Add an option to the context menu for customizing the tabbar toolbar

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: u88484, Unassigned)

References

Details

Add an option to the context menu for customizing the tabbar toolbar.  The menu and navigation toolbars both have an option in the right-click context menus but the tabbar does not.
Or just a 'Tabs on Top' check?
P.s. the current context menu on the tabbar is already crowded, and could use some (late spring) cleaning.
(In reply to comment #1)
> Or just a 'Tabs on Top' check?
> P.s. the current context menu on the tabbar is already crowded, and could use
> some (late spring) cleaning.

I don't think that option should be added because I doubt users are going to change the positioning of tabs that much to warrant a context menu entry.

A customize option could be used a lot more.  Especially now on vista and window 7 that the menu bar is hidden by default and the navigation bar has barely any clickable area to get the context menu.  Right-clicking anywhere on the tabbar though activates the context menu where a user could customize their toolbars to add/remove/move buttons.
Now that the customizable tabbar patch has landed, this would be great!  Do we not have wanted1.9.* flags anymore?
Blocks: 457187
No longer blocks: 457187
If I've understood the request in this bug correctly, this now works.  Right-clicking in a blank area of the tab bar now offers the same menu options available by right-clicking on a blank area of any other toolbar.  I think that addresses the original request ("The menu and navigation toolbars both have an option in the right-click context menus but the tabbar does not.").  If not, please feel free to comment further or reopen.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Duplicate of this bug: 649183
You need to log in before you can comment on or make changes to this bug.