The default bug view has changed. See this FAQ.

Intermittent failure in reftest suite: no output in 330 seconds during shutdown

RESOLVED WORKSFORME

Status

Testing
Reftest
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Windows Server 2003
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?tree=Firefox&errorparser=unittest&logfile=1269251710.1269255098.18990.gz&buildtime=1269251710&buildname=WINNT%205.2%20mozilla-central%20debug%20test%20reftest&fulltext=1#err0
WINNT 5.2 mozilla-central debug test reftest on 2010/03/22 02:55:10

TEST-UNEXPECTED-FAIL | automation.py | application timed out after 330 seconds
with no output

command timed out: 1200 seconds without output
program finished with exit code 1
elapsedTime=2933.906000
TinderboxPrint: reftest<br/>4267/0/277
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without
output
TinderboxPrint: reftest<br/><em class="testfail">timeout</em>

It seems that for some reason, nothing was written on stdout for 330 seconds.  This seems to has happened during shutdown.

Comment 1

7 years ago
Created attachment 433985 [details]
relevant part of the log

Comment 2

7 years ago
It looks like crashinject failed, too, so we don't have stacks for the hang :(
Version: unspecified → Trunk
Is it possible that http://tinderbox.mozilla.org/showlog.cgi?tree=Firefox&errorparser=unittest&logfile=1270007306.1270009110.2283.gz&buildtime=1270007306&buildname=WINNT%205.2%20mozilla-central%20debug%20test%20mochitests-3%2f5&fulltext=1 is another example of this bug? That one crashed for realsies, but it crashed in lock code, which makes me think that it could potentially be a deadlock situation that sometimes crashes?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275761778.1275765046.7409.gz
WINNT 5.2 mozilla-central debug test reftest on 2010/06/05 11:16:18
s: mw32-ix-slave12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276142467.1276143860.9591.gz
WINNT 5.2 mozilla-central debug test reftest on 2010/06/09 21:01:07
s: mw32-ix-slave07
Comment 5 isn't actually this.
Comment hidden (Treeherder Robot)
Duplicate of this bug: 571136
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278022134.1278025919.4957.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest-d2d on 2010/07/01 15:08:54
s: talos-r3-w7-023

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278022141.1278025494.2952.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest on 2010/07/01 15:09:01
s: talos-r3-w7-033
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278398477.1278401414.21488.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest on 2010/07/05 23:41:17

s: talos-r3-w7-024
TEST-UNEXPECTED-FAIL | Shutdown | application timed out after 330 seconds with no output
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282634671.1282638336.22571.gz
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

7 years ago
Depends on: 589496
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 44

6 years ago
Bug 616085 could have been one of the reasons that this has happened to our crashtests.
Depends on: 616085
Comment hidden (Treeherder Robot)
And since this was about reftest, not any of the other stuff that has piled on since, nothing after comment 19 was actually this, and this hasn't happened since last July.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

4 years ago
Keywords: intermittent-failure
(Assignee)

Updated

4 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.