Intermittent timeout after all reftests finish ("application timed out after 330 seconds with no output", "command timed out: 1200 seconds without output")

RESOLVED DUPLICATE of bug 554111

Status

()

RESOLVED DUPLICATE of bug 554111
8 years ago
8 years ago

People

(Reporter: adw, Unassigned)

Tracking

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
I don't understand the problem, if it's an issue with some reftest or the build system, but after all reftests finish in a buildstep, a bunch of windows close, the one containing 468263-2-ref.html being the last.  Some warnings then a timeout.

WINNT 5.2 mozilla-central debug test reftest on 2010/06/09 15:01:32
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276120892.1276125582.22779.gz

======== BuildStep started ========
'python reftest/runreftest.py ...' warnings
=== Output ===
python reftest/runreftest.py --appname=firefox/firefox.exe --utility-path=bin --extra-profile-file=bin/plugins --symbols-path=symbols reftest/tests/layout/reftests/reftest.list
 in dir e:\builds\moz2_slave\mozilla-central-win32-debug-unittest-reftest\build (timeout 1200 secs)
 watching logfiles {}
 argv: ['python', 'reftest/runreftest.py', '--appname=firefox/firefox.exe', '--utility-path=bin', '--extra-profile-file=bin/plugins', '--symbols-path=symbols', 'reftest/tests/layout/reftests/reftest.list']

... yada yada yada...

REFTEST FINISHED: Slowest test took 22093ms (file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-reftest/build/reftest/tests/layout/reftests/table-width/percent-zero.html)
REFTEST INFO | Result summary:
REFTEST INFO | Successful: 4422 (4411 pass, 11 load only)
REFTEST INFO | Unexpected: 0 (0 unexpected fail, 0 unexpected pass, 0 unexpected asserts, 0 unexpected fixed asserts, 0 failed load, 0 exception)
REFTEST INFO | Known problems: 235 (174 known fail, 8 known asserts, 36 random, 17 skipped)
REFTEST INFO | Total canvas count = 14
REFTEST INFO | Quitting...
Security Error: Content at file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-reftest/build/reftest/tests/layout/reftests/xul-document-load/test009.xul may not load data from file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-reftest/build/reftest/tests/layout/reftests/xul-document-load/not-existing.css.
WARNING: getting z level of unregistered window: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/xpfe/appshell/src/nsWindowMediator.cpp, line 606
WARNING: getting z level of unregistered window: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/xpfe/appshell/src/nsWindowMediator.cpp, line 606
--DOCSHELL 0402C9B8 == 2
--DOCSHELL 042D4668 == 1
--DOCSHELL 044B3148 == 0
--DOMWINDOW == 23 (044B10E4) [serial = 5] [outer = 00000000] [url = data:text/html,%3C%21%2D%2DCLEAR%2D%2D%3E]

... lots of domwindows are closed...

--DOMWINDOW == 2 (06951194) [serial = 12093] [outer = 00000000] [url = file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-reftest/build/reftest/tests/content/html/content/reftests/468263-2-ref.html]
WARNING: nsExceptionService ignoring thread destruction after shutdown: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/xpcom/base/nsExceptionService.cpp, line 197
TEST-UNEXPECTED-FAIL | automation.py | application timed out after 330 seconds with no output

command timed out: 1200 seconds without output
program finished with exit code 1
elapsedTime=4320.734000
TinderboxPrint: reftest<br/>4422/0/235
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output
TinderboxPrint: reftest<br/><em class="testfail">timeout</em>
=== Output ended ===
======== BuildStep ended ========
(Reporter)

Updated

8 years ago
Blocks: 438871
Whiteboard: [orange]
(Reporter)

Updated

8 years ago
Summary: Intermittent timeout after all reftests finish → Intermittent timeout after all reftests finish ("application timed out after 330 seconds with no output", "command timed out: 1200 seconds without output")
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 554111
No longer blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.