Closed Bug 554164 Opened 10 years ago Closed 5 years ago

reply to mail moved in local folders doesn't use default account if original recipient is not explicit

Categories

(MailNews Core :: Composition, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 327713

People

(Reporter: givrix, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3pre) Gecko/20100316 Ubuntu/9.10 (karmic) Namoroka/3.6.3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.10pre) Gecko/20100321 Shredder/3.0.5pre

I'm using filters for moving my mails from mailing lists to folders in Local Folders. Such mailing lists using mailman sever don't use personalized mails by default. The recipient of the mail is not mentioned in to: fields.

What happens is that Thunderbird is unable to fall back onto default account when it cannot determine the right account to use. In my case it's using the second one in the list.

Reproducible: Always

Steps to Reproduce:
1. Set up 2 accounts one with default set on.
2. Receive from the default address an email with anonymous recipient such as those from mailing lists
3. Move it to Local Folders
4. Try to reply to this mail by clicking reply, reply all or reply to list
5. Check the From: account in Message Compose Window
Actual Results:  
The account used for the replied mail is not the default one neither the one from which the mail origins.

Expected Results:  
There are to ways to solve this, the best one would be to keep every mail linked to the account it where received from. And if the To: field in the mail can't be linked to an account it would use the one from which the mail was received.
If this would imply too much drastic change, the first step would be to use the default account for the reply.

I've also tried this situation with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091222 Shredder/3.1a1pre. It leads to the same, so I believe it's not fixed yet.
Same problem as bug 327713?
No it's the opposite, in his case the mail is still in the original account's folder.
Me I've moved it to Local Folders.
Thunderbird doesn't use default account for reply.
But some other account for an unknown reason.

Eg :
A mail from mailing list is received on main account dude1@somthg.com with no To: field or irrelevant To: field like :
discussions@thing.com

I move it to Local Folders/Discussions/Thing.com

I reply to the mail.

The from field in the compose window is set to the other account dude2@somethg.com which is not default !
(In reply to comment #2)
> No it's the opposite, in his case the mail is still in the original account's folder.

Do you understand bug 327713 corectly? Bug 327713 is for "mail is moved to other account's folder than account who downloaded the mail" case.  
  Bug 327713: moved to folder of non "Local Folders" account,
              who is not Global Inbox owner for other POP3 accounts.
  Your case : moved to folder of pseudo account of "Local Folders".
              You probably don't use "Local Folders" as Global Inbox owner
              for other POP3 accounts.
Problem of Bug 327713 is: Tb always sets preset From: upon reply from X-Account-Key: header value, even though user never uses Global Inbox.
Not opossite, I believe. But, "Local Folders" case needs careful solution than Bug 327713, because "Local Folders" is used as defaulted Global Inbox owner.

Please check X-Account-Key: header of mail and mail.account.annountN.xxx settings and mail.identity.idP.xx settings in prefs.js(or via Config Editor).

Another concern.
Tb has "reply-to-myself" feature which often produces user's confusions and complaints about preset From:/To:/CC: upon reply/reply all.
  If mail of From:myself1,To: or CC:myself2, Tb sets From:myself1,
  To or CC:myself2 as preset From: etc. even though reply.
  (See Bug 377998) 
Does dude2@somethg.com appear in the mail from mailing list to be replyed?
Component: General → Untriaged
likely duplicate
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Component: Untriaged → Composition
Product: Thunderbird → MailNews Core
Resolution: --- → DUPLICATE
Duplicate of bug: 327713
You need to log in before you can comment on or make changes to this bug.