reloading the plugin window always opens a new instance of Addons Manager

VERIFIED FIXED in mozilla1.9.3a5

Status

()

defect
P2
normal
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: tchung, Assigned: Unfocused)

Tracking

Trunk
mozilla1.9.3a5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite][addons-testday], URL)

(Reporter)

Description

9 years ago
A new instance of Addons Manager is opened whenever your reloading a disabled plugin.  Instead, it should just detect the addons manager tab is already opened, and navigate to it.

Repro:
1) Download Addons project branch nightly: Mozilla/5.0 (Macintosh; U; Intel Mac
OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100321 Minefield/3.7a4pre
2) Install Flash, and open the addons manager in a seperate tab
3) goto Youtube.com, and start a flash video
4) while video is playing, go back to addons manager and Disable the flash plugin
5) youtube video stops, reload page, and then click the window region that says "The plugin for this content has been disabled. Click here to manage your plugins."
6) Verify a new instance of addons manager appears in a new tab.   repeat steps 2-5, and notice new instances of addons manager will keep appearing in new tabs.

Expected:
- if addons manager is already opened in a tab, it should always navigate to that open instance

Actual:
- new tabs of addons manager opens.
(Reporter)

Updated

9 years ago
Blocks: 550048
Whiteboard: [rewrite]
It doesn't only happen under such conditions. It's something we talked about in our first meeting without a solution so far. Shall we re-use the same tab for any access to the addons manager? That also included selecting "Tools | Add-ons".
Keywords: uiwanted
OS: Mac OS X → All
Hardware: x86 → All
Need to get Boriss' input on this, but I think the solution might be to switch to any existing Extension Manager tab (may need to restrict this to only tabs in the current window, if it feels weird changing windows) for any menu items, buttons, etc. But still let the user type "about:addons" in the location bar to load it in another tab.

Bug 480350 will provide the functionality to do this.
Depends on: switch-to-tab
Priority: -- → P2
Blocks: 552754
No longer blocks: 552754
Fixed as a side-effect of:
http://hg.mozilla.org/projects/addonsmgr/rev/5226a4d49278
Flags: in-testsuite-
Flags: in-litmus?
Whiteboard: [rewrite] → [rewrite][fixed-in-addonsmgr]
So the decision has been changed to only use a single add-ons manager window across all windows now?
Eh, I think getting this perfect is going to be a matter of seeing what users feel about the behavior. For now, I've gone with switching to a tab in any window (not necessarily in the current window) - so single addons manager across all windows, unless its opened manually by typing in a URL, or using a bookmark, etc.
I like it Blair but I just want to make sure it's the way we want to go. Jennifer should comment on it.

Btw, how do you handle the situation, when an user has opened another tab with the addons manager. Once you enable a plugin, which tab will be focused? The one which has been opened lately or the one which has been opened via Tools | Addons?
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
(In reply to comment #6)
> Btw, how do you handle the situation, when an user has opened another tab with
> the addons manager. Once you enable a plugin, which tab will be focused? The
> one which has been opened lately or the one which has been opened via Tools |
> Addons?

This uses code not specific to the addonsmgr branch - specifically, it was added by bug 480350, and has existing tests (automated and litmus). It will search tabs from left to right, first in the current browser window, then in other windows (I'm not sure if that's by the most recently used window or not). The tab search order may or may not change in the future - see the comments in bug 558354.

To answer your question: If the user opens about:addons manually, switches to some other tab, then uses Tools | Addons, this will switch to the tab they opened; such that there is only one addons manager tab. Similarly, clicking on some disabled plugin will also switch to the tab that they opened manually. The only way to open a 2nd addons manager tab is to type in about:addons to the location bar of a new tab *after* the addons manager is already open in a different tab.
Thanks for the clarification Blair!
Landed on trunk as a part of bug 554007
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [rewrite][fixed-in-addonsmgr] → [rewrite]
Target Milestone: --- → mozilla1.9.3a5
Added a better example as URL because Youtube only shows up the Flash disabled page for about a split of a second. With the Monkey Island trailer it's better reproducible.

Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100514 Minefield/3.7a5pre
Status: RESOLVED → VERIFIED
Keywords: uiwanted
Flags: in-litmus? → in-litmus?(vlad.maniac)
Litmus test has been added:
https://litmus.mozilla.org/show_test.cgi?id=15151
Flags: in-litmus?(vlad.maniac) → in-litmus+
Whiteboard: [rewrite] → [rewrite][addons-testday]
You need to log in before you can comment on or make changes to this bug.