Enabling the default theme after a personas was selected the install status image is broken

VERIFIED FIXED in mozilla1.9.3a5

Status

()

P1
normal
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: tchung, Assigned: Unfocused)

Tracking

Trunk
mozilla1.9.3a5
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 434160 [details]
default theme screenshot

Enabling Default Theme displays an odd status bar image.   See screenshot

Repro:
1) Download Addons project branch nightly: Mozilla/5.0 (Macintosh; U; Intel Mac
OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100321 Minefield/3.7a4pre
2) install a personas themes from getpersonas.com
3) Now reenable the Default theme
4) Verify strange images appear in appearance.

Expected:
- default theme gets renabled, with the right images

Actual:
- odd status bar icons in the default theme and the last selected persona
(Reporter)

Updated

9 years ago
Blocks: 550048
Whiteboard: [rewrite]
With status bar image you mean the buttons, e.g. "Remove" and "Enable"?
(Reporter)

Comment 2

9 years ago
yeah i guess its a merged remove and enable buttons.   THe screenshot makes it clear.
I've been referring to this as the install status.
It's something we can test as part of another Litmus test.
Flags: in-litmus?
Summary: Enabling Default Theme displays an odd status bar image → Enabling the default theme after a personas was selected the install status image is broken
(Reporter)

Comment 5

9 years ago
yeah its the install status, not the enable/disable buttons.   See spec screenshot: https://wiki.mozilla.org/File:Just_searching_onescreen.png
Duplicate of this bug: 555509
Priority: -- → P1
Assignee: nobody → bmcbride
Pretty sure this will be fixed by bug 561078.
Depends on: 561078
(In reply to comment #7)
> Pretty sure this will be fixed by bug 561078.

Yes, looks good now. Marking as fixed on the branch.
Status: NEW → ASSIGNED
Flags: in-testsuite?
Whiteboard: [rewrite] → [rewrite][fixed-in-addonsmgr]
Landed on trunk as a part of bug 554007
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [rewrite][fixed-in-addonsmgr] → [rewrite]
Target Milestone: --- → mozilla1.9.3a5
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100511 Minefield/3.7a5pre ID:20100511030640
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus?(vlad.maniac)
This sort of thing is difficult to test automatically but we should have a manual test for switching themes that should cover this.
Flags: in-testsuite? → in-testsuite-
(In reply to Dave Townsend (:Mossop) from comment #11)
> This sort of thing is difficult to test automatically but we should have a
> manual test for switching themes that should cover this.

Dave, do you think we should also have a litmus manual test for this one?
That's what he was saying in comment 11.
(In reply to Henrik Skupin (:whimboo) from comment #13)
> That's what he was saying in comment 11.

Thanks for clarifications Henrik
You need to log in before you can comment on or make changes to this bug.