Print Preview or Print to PDF on any webpage crashes Firefox [@ libobjc.A.dylib@0x15688 | HPSmartPrint@0xe1ef ]

RESOLVED DUPLICATE of bug 461355

Status

()

--
critical
RESOLVED DUPLICATE of bug 461355
9 years ago
8 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Every time I try to Print Preview or Print to PDF (which works correctly) Firefox will crash 5-30 seconds afterwards.

Reproducible: Always

Steps to Reproduce:
1. File -> Print
2. Print Preview
3. PDF -> Save As PDF
Actual Results:  
A short while after showing the preview or saving the pdf Firefox will crash 

Expected Results:  
Not crashed :)

libobjc.A.dylib@0x15688 | HPSmartPrint@0xe1ef

EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE

Crash Reports
bp-03ca909a-ebfb-4e94-9223-cba712100323	23/03/2010	11:13
bp-fca94f47-574e-43a4-b6e1-1c0442100301	01/03/2010	17:07
bp-627d6f35-f7a5-44e4-8189-4d15d2100301	01/03/2010	13:35
bp-a6c5c527-048c-406f-a147-dd0b52100301	01/03/2010	13:29
bp-6293e6ec-fb73-4998-9298-e12aa2100225	25/02/2010	18:17
bp-9718f7b2-8d15-40ef-b17c-848212100225	25/02/2010	17:45
bp-5a97968f-3419-4835-9cb2-5a17d2100225	25/02/2010	17:02
bp-4f464620-64c5-43e2-acbd-d40d92100225	25/02/2010	16:56
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch
Looks like a problem with the HP drivers
Summary: Print Preview or Print to PDF on any webpage crashes Firefox → Print Preview or Print to PDF on any webpage crashes Firefox [@ libobjc.A.dylib@0x15688 | HPSmartPrint@0xe1ef ]
(Reporter)

Comment 2

9 years ago
Just to add I'm pretty sure I didn't have these issues with Firefox 3.0-3.5.

Also add info to above:

Initially I hadn't installed any printer drivers however my Mac is sitting on a network with an HP LaserJet 3055 which OSX picked it up automatically.

I also have an HP Photosmart C3100 via USB and just installed the latest HP drivers both via HP & the Apple Software update.  I changed the printer from the LaserJet to the Photosmart printer - still get the same issue. 

Report here:
bp-1d7c18b3-5b37-4dc8-a139-50ae92100323	23/03/2010	17:18

Also if I output to pdf wouldn't this be using a different software driver? As this is just built-in functionality on the mac.  This also causes the issue...
Pretty sure this is a dupe of Bug 461355. There are also two other bugs on file with the same stack: 	 
Bug 489713
Bug 548187

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 461355
You need to log in before you can comment on or make changes to this bug.