multiple votes not allowed

VERIFIED FIXED in Bugzilla 2.12

Status

()

Bugzilla
Bugzilla-General
P3
normal
VERIFIED FIXED
18 years ago
6 years ago

People

(Reporter: Len Trigg, Assigned: Matthew Barnson)

Tracking

unspecified
Bugzilla 2.12
x86
Linux

Details

(Whiteboard: 2.12, URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
The help page states that multiple votes per bug is allowed (since you only have
a finite number of votes this is OK). However, if you try to allocate more than
one vote to a bug, you get an error messgage.

To reproduce: try to allocate more than 1 vote to a bug :-)
You can't multiple vote for anything in the Browser or MailNews product since
that was the choice of mozilla.org due to the silly way the UNCONFIRMED status
works with voting.  Multiple voting works in the Webtools product.

Leaving this open as this page needs to be updated to reflect the fact that not
all installations & products will necessarily have multiple voting capability.
(Reporter)

Comment 2

18 years ago
It's not just browser and mailnews -- I tried putting multiple votes in the PSM
category and got the same message. What is the problem with allowing multiple
votes? (And why is it supposedly only a problem with browser and mailnews?)
Shouldn't that problem be fixed instead?
Yes, that's to be expected, I just didn't know PSM allowed votes.

The reason is that these products that these allow an UNCONFIRMED status.

UNCONFIRMED will automatically turn into NEW once it has a certain number of
votes (about 3 I think).  Therefore, someone could assign of all their votes to
a bug to confirm it and then remove them.  The intention was that 3 different
people should have to assign their votes.

Removing multiple voting was a kludgy workaround to ensure this.  Better would
be if it checked the number of voters was >= 3.  Even better if there was a
confirmation points system separate from the voting system.

In any case however, I do think whether to allow multiple votes should be an
admin choice.  An admin choice I think should be on for all products in b.m.o I
might add.
Confirmation points => bug #56383

Comment 5

18 years ago
I don't like multiple votes, because they seem to skew the voting a lot 
(especially since most bugs have 0 votes).  I'm usually more interested in how 
many people have voted for a bug than whatever the current "number of votes" 
measures.
(Reporter)

Comment 6

18 years ago
Multiple votes essentially allows the user to specify some degree of importance
(to them) to assign to the bug. Since the total number of votes per person is
fixed, no overall bias towards one person occurs, but obviously some skew
towards particular bugs may (that's the *point* of having multiple votes).

Having multiple bug assignment doesn't preclude getting the information on the
number of people who voted for a bug.
Nom 2.12, small fix, doc change only.
Whiteboard: 2.12
Created attachment 22550 [details] [diff] [review]
Whoops!  Wrong diff!

Comment 10

18 years ago
A simple doc change certainly should be easy to include in 2.12  :)

If it means anything to you r=jake (I patched this on my existing install and 
all went well).  This will also be clearer if/when bug 31295 gets implimented.
Keywords: patch, review

Comment 11

18 years ago
barnboy -- another one to your list
Assignee: tara → mbarnson
Bug 31295 is in.  This doc change is still relevant.  Checking in...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
*** Bug 31180 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
Sorry for the spam, but I needed to be able to query for all of these correctly.
Target Milestone: --- → Bugzilla 2.12

Comment 15

18 years ago
V.
Status: RESOLVED → VERIFIED
Moving closed bugs to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.