[LAYER] javascript: url yields blank window

VERIFIED FIXED

Status

P1
critical
VERIFIED FIXED
18 years ago
4 years ago

People

(Reporter: mikepinkerton, Assigned: bc)

Tracking

({top100})

Details

(Whiteboard: [rtm-], URL)

(Reporter)

Description

18 years ago
on the www.foxnews.com front page, there is a url:

javascript:camCentral('text=/elections/campaign_central/poll_channel.sml','photovideo=/elections/campaign_central/poll_vote.html');

clicking it brings up a new window that is white, but no content. I've seen this
on other websites that have javascript: popups, like CNN.
(Reporter)

Comment 1

18 years ago
cc'ing brendan, though i doubt it has anything to do with him. branch build from
10/5/00. don't know if it worked on beta3, but it happens on a trunk build from
a few days ago as well. happens on win32 as well. marking platform all.
Keywords: correctness, rtm, top100
OS: Mac System 9.0 → All
Hardware: Macintosh → All

Comment 2

18 years ago
dupe of 36081? exact same summary.

Comment 3

18 years ago
Seems like the javascript on the front page works fine, but the window that it 
brings up doesn't show anything.

The windows that come up (for example, 
http://www.foxnews.com/elections/campaign_central/index.sml) is just a huge 
block of JavaScript that draws frames in different ways depending on the 
browser, screen resolution, whether you have flash, etc.

Afaict the script boils down to

var ns = (document.layers)? true:false; 
var ie = (document.all)? true:false;
var bigRes = false;
var smallRes = false;

if (ns) { figure out screen resolution in a netscapy way }
if (ie) { figure out screen resoultion in a microsofty way }

if (smallRes) { draw frames that work nicely at low resolution }
else if (bigRes) { draw frames that work nicely at high resolution }
// (no else branch, so nothing is drawn on other browsers. oops.)

Comment 4

18 years ago
So, has anyone reproduced a simplified testcase for this?  It seems like this 
could be a problem in the javascript function itself.

This is top100, but it's not their front page.  I'd be leaning to rtm- unless we 
can prove there's a real problem here.
Whiteboard: [need info]

Comment 5

18 years ago
reassigning.  I'm not a good owner for this bug.
Assignee: asa → rogerl
Component: Browser-General → Javascript Engine
QA Contact: doronr → pschwartau

Comment 6

18 years ago
The camCentral() function, called with the arguments provided by the 
reporter above, constructs the following URL :


http://www.foxnews.com/elections/campaign_central/index.sml?text=/elections/camp
aign_central/poll_channel.sml&photovideo=/elections/campaign_central/poll_vote.h
tml



Jesse has hit on the answer at 2000-10-17 20:53 above. The script 
at http://www.foxnews.com/elections/campaign_central/index.sml 
uses insufficient browser detection:


            var ns = (document.layers)? true:false; 
            var ie = (document.all)? true:false;


Since N6/Mozilla does not support layers or document.all, both these 
variables evalualte to false for the rest of the script. But the script 
relies on them to decide what HTML to write. For example:


/************************************************************************
*  START PRINTING FRAMESET DEPENDING ON SCREEN DIMENSIONS, BROWSER TYPE *
*  AND FLASH PLUGIN                                                                                                     
*************************************************************************/

if (WM_easyDetect('flash') && bigRes) {  //1024
  document.writeln('<frameset framespacing="0" border="0" rows="60,294,*" 
frameborder="0">');
  document.writeln('<frame name="header" scrolling="no" noresize 
src="header.html">');


if (ns) 
{
  document.writeln('      <frameset framespacing="0" border="0" 
cols="110,346,330" frameborder="0">');
} 

else if (ie) 
{
  document.writeln('      <frameset framespacing="0" border="0" 
cols="110,346,334" frameborder="0">');
}
 
               
document.writeln('<frame name="nav" scrolling="no" noresize src="blank.htm">');
document.writeln('<frame name="text" scrolling="auto" noresize src='+text+'>');
document.writeln('<frame name="photo" scrolling="no" noresize 
src='+photovideo+'>');
document.writeln('</frameset>');
document.writeln('<frame name="timeline" src="blank.htm" scrolling="no" 
noresize>');
document.writeln('                      </frameset>');

                        etc.
                        etc.


Since the script uses no third, default case besides "ns" and "ie",
the HTML doesn't get completely written...


Reassigning to Evangelism component -
Assignee: rogerl → blakeross
Component: Javascript Engine → Evangelism
QA Contact: pschwartau → zach

Updated

18 years ago
Summary: javascript: url yields blank window → [LAYER] javascript: url yields blank window

Comment 7

18 years ago
if this is evangelism component for the web site to change, then this has to be
rtm-, I think.  Blake, if you think so, pls mark rtm-.

Comment 8

18 years ago
yes, [rtm-].  Evangelism bugs can't be +'d.  But foxnews.com is an important 
site, so this is top priority for 6.0
Severity: major → critical
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [need info] → [rtm-]
Target Milestone: --- → mozilla0.6

Comment 9

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Status: ASSIGNED → NEW

Updated

18 years ago
Target Milestone: mozilla0.6 → Future

Comment 10

18 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
(Assignee)

Comment 11

18 years ago
foxnews no longer has any content at or below http://www.foxnews.com/elections/.
Marking fixed. If foxnews has other evangelism issues please open a new bug for
them.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
can't find any javascript: links, verifying.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 13

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Target Milestone: Future → ---
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.