right-click on .jpg attachments -> open does not open an external viewer selection

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: jd1008, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8) Gecko/20100216 Fedora/3.5.8-1.fc12 Firefox/3.5.8
Build Identifier: thunderbird-3.0.3-1.fc12.i686

I have set in my view option to NOT show jpeg attachments inline
as that slows thunderbird to an absolute crawl.
So, I wanted to right click on the jpg attachment, and was expecting
a pop-up menu to let me select the app with which to open the 
attachment. Well it only pops up a menu with
open, save, detach and delete options.
Selecting open does the same thing as save.
How do I fix this so I am given a set of options as
to what external viewer to use to view the attachment?


Reproducible: Always

Comment 1

9 years ago
Duplicate of MailNews Core bug 244260 -> Core bug 58554 and/or MailNews Core bug 266949?

Comment 2

9 years ago
Since Thunderbird doesn't have a browser component, it shouldn't be affected by either of these Core bugs (SeaMonkey still is). Testing Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4 gives me an "Open with" dialog for both double-clicking and right-click > Open on the attachment icon for Content-Disposition: inline; and Content-Type: image/jpeg; with View > Display Attachments Inline disabled (that's Windows though, may be different on Linux).
(Reporter)

Comment 3

9 years ago
When I submitted this bug, I did state:
thunderbird-3.0.3-1.fc12.i686 
Which is Fedora Linux.
So, I am not talking about the windows platform version of TB.

Comment 4

9 years ago
I know - I was mainly responding to comment #1 listing Mozilla Suite/SeaMonkey bugs, which don't seem to apply in your case = no duplicate of those.

Updated

8 years ago
Component: General → Message Reader UI
QA Contact: general → message-reader

Comment 5

5 years ago
JD do you see this when using a current version?
Flags: needinfo?(jd1008)
Whiteboard: [closeme 2014-01-15]
(Reporter)

Comment 6

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #5)
> JD do you see this when using a current version?

Well, I am on latest TB on FC18.
I will test when I get home this evening.
Flags: needinfo?(jd1008)

Comment 7

5 years ago
(In reply to JD from comment #6)
> I will test when I get home this evening.

And result is?
Flags: needinfo?(jd1008)
Whiteboard: [closeme 2014-01-15] → [closeme 2014-02-01]
(Reporter)

Comment 8

5 years ago
In TB 24.2.0, it works!
Thanx!
Please close as fixed.
Flags: needinfo?(jd1008)

Comment 9

5 years ago
Thanks, resolving WFM as it's not clear what caused (or ultimately fixed) it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2014-02-01]
You need to log in before you can comment on or make changes to this bug.