Menu banner is now glass and is hard to see?????

RESOLVED FIXED in Firefox 4.0b5

Status

()

Firefox
Theme
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: Bee, Assigned: dao)

Tracking

unspecified
Firefox 4.0b5
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100329 Minefield/3.7a4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100329 Minefield/3.7a4pre

Hi the menu banner at the top is glass now and is hard to read the text after the newest update.  Please correct this thanks.  

Reproducible: Always
Welcome to the world of pre-alpha builds.  The change was intended, and is part of a WIP (Work in Progess) see the mockups here for more of what is coming.

https://wiki.mozilla.org/Firefox/Sprints/Windows_Theme_Revamp/Direction_and_Feedback
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Assignee)

Updated

8 years ago
Blocks: 546259
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

8 years ago
Screenshot: https://bug546259.bugzilla.mozilla.org/attachment.cgi?id=435126

This was discussed in bug 546259 from comment 19 onwards, although I didn't see comments from the people responsible for the theme work.
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> Screenshot: https://bug546259.bugzilla.mozilla.org/attachment.cgi?id=435126

That's outdated.
I think simple text-shadow could do the trick. I believe the same way is Win7 handling text in titlebar. And is working just fine.
(Assignee)

Comment 5

8 years ago
Text shadow is being used already.
Use stronger and/or bigger shadow, the current one isn't sufficient.

Updated

8 years ago
blocking2.0: --- → ?
(Assignee)

Updated

8 years ago
Duplicate of this bug: 571666
(Assignee)

Comment 8

8 years ago
Created attachment 451889 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #451889 - Flags: review?(gavin.sharp)
More readable menu item text could be achieved by using DrawThemeTextEx as in this example: <http://msdn.microsoft.com/en-us/library/bb688195%28v=VS.85%29.aspx#appendixb>.  (That's for drawing the window caption, but using the same glow effect is what you want, I guess.)  Also you'd need a way of mapping some CSS to text being rendered with DrawThemeTextEx...

Updated

8 years ago
Duplicate of this bug: 575247
blocking2.0: ? → betaN+
(Assignee)

Updated

8 years ago
Duplicate of this bug: 588805

Comment 12

8 years ago
(In reply to comment #8)
> Created attachment 451889 [details] [diff] [review]

I think, this looks weird. I suggest making the window completely opaque in non-firefox-button-mode, similar to the Firefox 3.x style, but of course with the new button and tab style and the other improvements.
Comment on attachment 451889 [details] [diff] [review]
patch

r=me, but this should really get ui-review (looks kind of weird to me too)
Attachment #451889 - Flags: review?(gavin.sharp) → review+

Comment 15

8 years ago
That fix looks kinda weird.  Why not just make the text white?  That's what vista does for window titles when you maximize the window.

Comment 16

8 years ago
(In reply to comment #15)
> Why not just make the text white?

Well, because the background currently is glass and not black (and at least on Windows 7 on maximized windows) and depending on the user preferences this glass is likely light blue or even white and therefore white text would be even more invisible.

Note that Windows User Experience Guidelines say, that you shouldn't use glass behind menu bars (or in general areas with text, see bug 588805 for details), so I think removing the glass in the client area would be the simplest and best solution for the classic menu bar case.

Comment 17

8 years ago
So make it white only for vista when the window is maximized, since this issue only occurs on vista.  Despite what settings you use in the "Window Color and Appearance", its impossible for that area to be white when the window is maximized.  At worst, its a light gray and white is still readable on it.

Comment 18

8 years ago
Created attachment 468789 [details]
Windows 7 screenshot
Feels like shorlander should be the one to make the call, here.
(In reply to comment #19)
> Feels like shorlander should be the one to make the call, here.

Something like this is the right approach I think. It could probably even be a little more opaque. Maybe .5 instead of .3?
(Assignee)

Comment 21

8 years ago
landed with 0.5:
http://hg.mozilla.org/mozilla-central/rev/5c7637322904
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b5

Updated

8 years ago
Duplicate of this bug: 584297
You need to log in before you can comment on or make changes to this bug.