vertical line on tab thumbnails on about:home

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
--
minor
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: aakashd, Assigned: vingtetun)

Tracking

({polish})

Fennec 1.1
polish

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.3pre) Gecko/20100330 Namoroka/3.6.3pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.3a4pre) Gecko/20100330 Namoroka/3.7a4pre Fennec/1.1a2pre

Steps to Reproduce:
1. Go to about:home
2. Open the tab sidebar and view the thumbnail

Actual Results:
There's a gray colored vertical line on the right-center portion of the thumbnail

Expected Results:
I shouldn't see a gray colored vertical line
(Reporter)

Updated

8 years ago
Severity: normal → minor
Duplicate of this bug: 559848
(Reporter)

Updated

8 years ago
Keywords: polish
This looks like a platform bug, refreshing the page once make the vertical line lighter and refreshing again make it gone!

I've dump some values from renderRectToCanvas for this and each time the values are identical.
Created attachment 441836 [details] [diff] [review]
workaround

This is a workaround for this bug.

This "line" is not related to our usual linux bug for this type of lines (bug  468496) because it has been confirmed that this is also seen on Mac OSX.
And I can also see the issue on windows.
Comment on attachment 441836 [details] [diff] [review]
workaround

I've open bug 562337 as a platform bug for this particular case.

So, i think we should take the workaround while 562337 is not fixed.
Attachment #441836 - Flags: review?(mark.finkle)
Comment on attachment 441836 [details] [diff] [review]
workaround

I think we do the same workaround here:
http://mxr.mozilla.org/mobile-browser/source/chrome/content/TileManager.js.in#808

for bug 534054

Is bug 556046 really a dupe of bug 534054?
Attachment #441836 - Flags: review?(mark.finkle) → review+
Oops bug 556046 is this bug
Vivien, I wonder if we should "+ 1" for the height as well. I am guessing that the thumbnail is smaller than a single tile (for height) and that is why we don't see horizontal lines. But maybe we should apply the same workaround for height.
Created attachment 442110 [details] [diff] [review]
Patch

This seems do to the work reasonably even if the UI is fullscreen on desktop.
Attachment #441836 - Attachment is obsolete: true
Attachment #442110 - Flags: review?(mark.finkle)
Attachment #442110 - Flags: review?(mark.finkle) → review+
pushed m-b:
http://hg.mozilla.org/mobile-browser/rev/ac90676a2807

pushed m-1.1:
http://hg.mozilla.org/releases/mobile-1.1/rev/ba1a4aa2835a
Assignee: nobody → 21
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

8 years ago
veirfied FIXED on build:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100429 Namoroka/3.6.5pre Fennec/1.1b2pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.