Last Comment Bug 534054 - Black horizontal lines on some sites
: Black horizontal lines on some sites
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Maemo
: -- blocker (vote)
: ---
Assigned To: Doug Turner (:dougt)
:
:
Mentors:
Depends on: 660740 468496
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-10 14:23 PST by Doug Turner (:dougt)
Modified: 2013-12-10 09:59 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v.1 (1.35 KB, patch)
2009-12-10 14:51 PST, Doug Turner (:dougt)
ben: review-
Details | Diff | Splinter Review
just what we need + comment. (892 bytes, patch)
2009-12-10 21:56 PST, Doug Turner (:dougt)
ben: review+
Details | Diff | Splinter Review

Description Doug Turner (:dougt) 2009-12-10 14:23:19 PST
Some sites, like:

http://www.npr.org/templates/story/story.php?storyId=120574256

incorrectly display horizontal black lines at the border of some tiles.  This maybe be caused by 468496.
Comment 1 Aakash Desai [:aakashd] 2009-12-10 14:29:17 PST
This has been known for awhile ( the testdays found this back in b4 as well https://bugzilla.mozilla.org/show_bug.cgi?id=520261 ) and stuart said that its due to that bug, doug.

*** This bug has been marked as a duplicate of bug 468496 ***
Comment 2 Doug Turner (:dougt) 2009-12-10 14:46:02 PST
this bug is for a potential work around in fennec around the bug in GFX.
Comment 3 Doug Turner (:dougt) 2009-12-10 14:51:56 PST
Created attachment 416980 [details] [diff] [review]
patch v.1
Comment 4 Benjamin Stover (:stechz) 2009-12-10 15:00:47 PST
Comment on attachment 416980 [details] [diff] [review]
patch v.1

This patches two functions.  Could you try just one or the other to make sure we are doing the minimal amount of work?
Comment 5 Doug Turner (:dougt) 2009-12-10 21:08:29 PST
just the second part of the patch is needed.
Comment 6 Doug Turner (:dougt) 2009-12-10 21:56:14 PST
Created attachment 417039 [details] [diff] [review]
just what we need + comment.
Comment 7 Benjamin Stover (:stechz) 2009-12-11 09:39:36 PST
Comment on attachment 417039 [details] [diff] [review]
just what we need + comment.

>diff --git a/chrome/content/TileManager.js.in b/chrome/content/TileManager.js.in
>+                   rect.left -1 , rect.top -1,
>+                   rect.right - rect.left + 1, rect.bottom - rect.top + 1,

Nit: space between - and 1.
Comment 8 Doug Turner (:dougt) 2009-12-11 09:48:59 PST
http://hg.mozilla.org/mobile-browser/rev/b3ed77e0d9ab
Comment 9 Aakash Desai [:aakashd] 2009-12-14 09:19:21 PST
verified FIXED On builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091214 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091214 Firefox/3.7a1pre Fennec/1.0b5


...but found an edge case with overlapping images that's filed on bug 534645

Note You need to log in before you can comment on or make changes to this bug.